Bug 466768 - Can't run system-config-* tools that requires privileged access
Can't run system-config-* tools that requires privileged access
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
Depends On: 467913 467915 467916 467918 467919 467920 467921 467922 467923 467924 467925
Blocks: F10Preview F10DesktopBlocker
  Show dependency treegraph
Reported: 2008-10-13 10:44 EDT by Edney Matias
Modified: 2008-10-27 14:43 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-10-27 14:43:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Edney Matias 2008-10-13 10:44:34 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; pt-BR; rv: Gecko/2008100707 Fedora/3.0.2-1.fc10 Firefox/3.0.2

I'm running kde 4.1.2 and am trying to access administration tools without success. Whenever i launch one of these tools that requires privileged access, the cursor bounces on screen, the task bar shows the icon from the window, but after some seconds it's dismissed and the cursor stops bouncing and no windows is opened. When i try this on konsole, i got a prompt asking my password and the window is opened. This happend with almost any system-config tool that needs password to open.

These doesn't work:
 - /usr/bin/system-config-network
 - /usr/bin/system-config-boot
 - /usr/bin/system-config-date
 - /usr/bin/system-config-firewall
 - /usr/bin/system-config-language
 - system-config-printer
 - /usr/bin/system-config-lvm
 - /usr/bin/system-config-selinux
 - /usr/bin/system-config-rootpassword
 - /usr/bin/system-config-display
 - /usr/bin/system-config-users

These is the one that actually worked:
 - /usr/bin/system-config-services
 - /usr/bin/system-control-network

These are from System menu and doesn't work also:
 - /usr/bin/selinux-polgengui

Reproducible: Always

Steps to Reproduce:
1. Install Fedora 10 KDE LiveCD
2. Go to Administration menu and click on one of the items
3. Watch the cursor bounce without any window opening
Actual Results:  
Cursor bouncing, icon on task bar and no window;

Expected Results:  
On Fedora 9, the cursor used to bounce, the task bar used to show the icon and after awhile the window asking my password used to open. This is the expected result on Fedora 10, i think.

Don't know what else i can provide. But if you ask, i will.
Comment 1 Matthias Clasen 2008-10-15 18:38:15 EDT
Most of these tools have nothing at all to do with PolicyKit.

Tentatively moving to KDE, since "running under KDE" seems to be the only common factor here...
Comment 2 Kevin Kofler 2008-10-15 18:47:07 EDT
consolehelper from usermode-gtk is what these tools use to get root.

Is there anything new in F10 we have to do in KDE to get consolehelper to work?
Comment 3 Ngo Than 2008-10-16 07:39:22 EDT
i have latest rawhide (today) running on my test machine. I cannot reproduce this problem. It seems something is broken in Fedora 10 KDE LiveCD?
Comment 4 Rex Dieter 2008-10-16 07:49:54 EDT
Or that the system-* tools or usermode has missing deps.
Comment 5 Edney Matias 2008-10-16 08:02:46 EDT
I think maybe Rex ir right cause i have a gnome-session installed even when i installed from kde live cd and the system-* tools doesn't work there too.
Comment 6 Miloslav Trmač 2008-10-16 15:35:19 EDT
Do you have usermode-gtk installed?  (Run (rpm -q usermode-gtk) in a terminal.)
Comment 7 Edney Matias 2008-10-16 22:50:40 EDT
Nop, i didn't have usermode-gtk. I installed and everything worked. So something is wrong with kde live? 

BTW thank you for your support.
Comment 8 Kevin Kofler 2008-10-16 22:53:08 EDT
So the bug is that those tools are all missing a dependency on usermode-gtk?
Comment 9 Kevin Kofler 2008-10-16 22:54:36 EDT
CCing Sebastian Vahl, the KDE live CD maintainer, he may want to manually pull in usermode-gtk onto the spin. (Still, I think there should be a dependency if the tools aren't going to work without it!)
Comment 10 Ngo Than 2008-10-17 06:09:30 EDT
there's only a dependency on usermode but not on usermode-gtk in the system tools. I will fix it in our system tools.
Comment 11 Sebastian Vahl 2008-10-17 06:17:23 EDT
(In reply to comment #10)
> there's only a dependency on usermode but not on usermode-gtk in the system
> tools. I will fix it in our system tools.

Ok then. Or should I also add it to the kickstarts?

BTW: It is possible that the applications design of the system-config-tools has changed in some way? What I mean: I could start system-config-services and it seems to be working. If I want to disable a service there, a PoliciKit window pops up and asks me for the root password. system-config-date and system-config-firewall want's this password before starting the application.
Comment 12 Kevin Kofler 2008-10-17 07:14:20 EDT
Looks like system-config-services has been ported to use PolicyKit instead of running as root entirely, system-config-date and system-config-firewall are still using usermode-gtk (which runs the entire application as root). That's also why system-config-services works without usermode-gtk and the others don't.
Comment 13 Ngo Than 2008-10-17 07:23:43 EDT
only system-config-services and system-config-samba supports PolicyKit and the rest not.
Comment 14 Tom "spot" Callaway 2008-10-27 14:43:23 EDT
All of the other system-config-* packages now have Requires: usermode-gtk in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.