Bug 469882 (CVE-2008-4815)

Summary: CVE-2008-4815 Adobe Reader: insecure RPATH flaw
Product: [Other] Security Response Reporter: Josh Bressers <bressers>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: bressers, kreilly, krh
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://nvd.nist.gov/nvd.cfm?cvename=CVE-2008-4815
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-13 15:36:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 469916, 469917, 469918    
Bug Blocks:    

Description Josh Bressers 2008-11-04 16:16:49 UTC
Adobe Reader was built to use insecure RPATH in the binary.

This issue could possibly be exploited by a local attacker to run arbitrary
code as some other user if victim user can be convinced to run Adobe Reader
in an attacker controlled directory with specially crafted content.

Comment 2 Tomas Hoger 2008-11-05 08:24:03 UTC
Public now via upstream security bulletin:
  http://www.adobe.com/support/security/bulletins/apsb08-19.html

Comment 4 Red Hat Product Security 2008-11-13 15:36:49 UTC
This issue was addressed in:

Red Hat Enterprise Linux Extras:
  http://rhn.redhat.com/errata/RHSA-2008-0974.html