Bug 471607

Summary: [Egenera 5.4 bug] No networking devices seen in virt-manager when installing guests
Product: Red Hat Enterprise Linux 5 Reporter: Chris Tatman <ctatman>
Component: virt-managerAssignee: Daniel Berrange <berrange>
Status: CLOSED NOTABUG QA Contact: Virtualization Bugs <virt-bugs>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 5.2CC: andriusb, crobinso, tao, xen-maint
Target Milestone: rc   
Target Release: 5.4   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-01-21 17:03:10 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 452260    
Bug Blocks: 471638    

Comment 2 Daniel Berrange 2008-11-14 17:12:45 EST
I thought this would be a bug in virt-manager talking to HAL, but that bit seems to be working OK according to logs. The core issue appears to be just that HAL isn't listing any network devices, and since virt-manager relies on HAL, we can't present any devices. So fixing HAL should fix virt-manager
Comment 5 Cole Robinson 2009-01-21 17:03:10 EST
Okay, from the looks of it, there is no virt-manager bug like Dan states. When bug 452260 (the underlying hal issue) is fixed, virt-manager should just work. If that is not the case, please reopen this bug, and attach the previously requested info, this time with a working hal underneath:

lshal output
ifconfg -a output
~/.virt-manager/virt-manager.log
ls sys/class/net output

Until then, I'm closing this as NOTABUG. Please link any Issue Trackers to 452260.