Bug 471737

Summary: dmraid problems - Intel ICH9R raid not recognized by Fedora 10 Preview
Product: [Fedora] Fedora Reporter: Tomas Lanik <kvantanet>
Component: dmraidAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: medium    
Version: 10CC: agajania, agk, andris.pavenis, arechenberg, atorkhov, bmr, bobgus, dimi, dmitryburstein, dnovotny, dwysocha, ecd77526c7e5, franta, hdegoede, heinzm, jaslopes, jchortala, lvm-team, maxim.yegorushkin, mbroz, pato.lukaz, prockai, raina, serge, wstering
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-03-08 04:19:53 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tomas Lanik 2008-11-15 07:25:05 EST
Description of problem: 

Server: PRIMERGY RX100 S5
Make: Fujitsu Siemens Computers
Processor: 1x Xenon Quad Core/ 2xSATAII 500GB / RAID chip Intel ICHR9 /motherboard FSC
Will be affecting also PRIMERGY Econel Servers with RAID chip Intel ICHR9 


We have configured a RAID 1 array on Intel ICH9R raid. Which in fact uses LSI firmware and appear like LSI Software SATA RAID Bios Version: A.06.05071459R 

This is a fakeRAID so dmraid is used to deal with it.

A) Using Fedora 10 Preview the RAID array is not recognized at all. 
In the anaconda installer just appear 2 separate SATA disks.

B) Using Fedora 9 and Fedora 10 Beta the RAID array is recognized but when booting appears an error message which is actually not affecting the functionality of the OS (The system boots up OK).

Error:
<SNIP>
Setting hostname localhost.localdomain                  [OK] 
/etc/rc.d/rc.sysinit: line 350: 1336 Segmentation fault /sbin/dmraid.static -ay -i -p 
"$dmname" > /dev/null 2>&1
Setting up Logical Volume Management : 2 logical volumes........  
</SNIP>

Version-Release number of selected component (if applicable):
F10 Preview x86_64 DVD
F10 Beta x86_64 DVD
F9 Release x86_64 DVD

How reproducible:
1) When using anaconda installer F10 x68_64 the RAID array is not recognized 
   by dmaraid and appears like 2 separate SATA disks.
2) When using anaconda installer F9 x68_64 or F10 Beta x86_64 the RAID array is properly recognized but error mesage is shown when booting the OS.

Error: 
<SNIP>
Setting hostname localhost.localdomain                  [OK] 
/etc/rc.d/rc.sysinit: line 350: 1336 Segmentation fault /sbin/dmraid.static -ay -i -p 
"$dmname" > /dev/null 2>&1
Setting up Logical Volume Management : 2 logical volumes........  
</SNIP>

Steps to Reproduce:

A)
1. boot F10 x86_64 DVD installation DVD
2. Process with installation until the partitioning
2. When in partitioning setup screen the array is not recognized 

B) 

1. boot F9 x86_64 or F10 Beta x86_64 installation DVD
2. Process with installation until the partitioning
3. When in partitioning setup screen the array is properly recognized
4. Finish the default installation
5. When booting the OS the error message will show up.


Actual results:
ICH9R RAID1 not recognized by kernel, dmraid. Fujitsu Siemens servers PRIMERGY RX100S5 and PRIMERGY Econel using the same chip are affected.

Expected results:
ICH9R RAID1 recognized and shown via device mapper.

Additional info:
on request
Comment 1 Bug Zapper 2008-11-26 00:26:53 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Dimi Paun 2008-11-28 16:13:01 EST
Same problem here with  Intel ICH8R RAID using Fedora 10 Final.
Comment 3 J.C. Hortala 2008-11-29 05:53:57 EST
Same problem here with Intel ICH7R and Fedora 10 DVD x86_64.
Comment 4 Serge Droz 2008-11-29 11:55:09 EST
Same here:
RAID bus controller: Intel Corporation 82801 SATA RAID Controller (rev 02)
Fedox 10 netinstall x86_64
Comment 5 Frantisek Hanzlik 2008-12-01 17:28:21 EST
Same problem with ICH9R (HP Proliant ML310 G5) Fedora 10 i386 Final
Comment 6 Wolfi 2008-12-07 12:07:32 EST
I have the same problem here with a Dell Precision 5400 machine, Intel 5400
Chipset (aka Seaburg). lspci reports "RAID bus controller: Intel Corporation
631xESB/632xESB SATA RAID Controller (rev 09)".

Fedora 9 works with the SATA RAID, when I tried to install Fedora 10, it didn't
recognize the RAID, but reported two independent disks.

To find out, if this was an anaconda issue, I installed Fedora 9 (freshly)
and then did a yum-based upgrade to Fedora 10 (as described in
http://fedoraproject.org/wiki/YumUpgradeFaq), to avoid having to use the F10
installation media.  Unfortunately this didn't solve the problem either.

So I'll have to reinstall a new F9 and wait (somewhat frustrated) for updated
F10 setup media, apparently...
Comment 7 Serge Droz 2008-12-08 12:14:09 EST
Well, just for the record:
You can run Fedora 10, just keep the Fedora 9 kernels installed after the yum upgrade.
Also, add the line 
exclude=kerne* 
to the fedora-update.repo file.

Regards
Serge
Comment 8 Dmitry Burstein 2008-12-08 13:10:36 EST
I've just filed Bug #475003 which is IMO the cause of this problem.
Presently I'm running F10 with the last F9's kernel (updated via yum) - with no mentionable problems.
Comment 9 Heinz Mauelshagen 2008-12-10 12:52:26 EST
This can be another incarnation of anaconda (nash) bz#471689 (see description, how repoducible), which is in the works to fix in F10 too. Keeping component dmraid because of the segmentation fault reported until we've got results after an F10 fix.
Reassigning to anaconda-maint-list to close the loop.
Comment 10 Andrew Rechenberg 2008-12-16 13:35:47 EST
Same issue here on a Dell Optiplex 755.  F9 worked fine.  Upgraded to F10 and could not boot (just got the grub> command line).

Using ICH9R
Comment 11 ecd77526c7e5 2009-01-01 09:59:16 EST
Same error in Fedora 10 with ICH7R.
I'm still using old Fedora 9 kernel...

Is there any easy solution? Or just to wait? Maybe it's better to downgrade to fc9?
Comment 12 Bob Gustafson 2009-01-22 11:44:13 EST
See also Bug #474399 and Bug #476818
Comment 13 Maxim Egorushkin 2009-02-05 17:22:36 EST
Same issue with http://download.fedoraproject.org/pub/fedora/linux/releases/10/Live/x86_64/F10-x86_64-Live.iso and ICH9R.
Comment 14 Daniel Novotny 2009-03-04 09:27:13 EST
same issue with Dell Precision T5400
Comment 15 Serge Droz 2009-03-07 04:37:23 EST
Hello,

I followed the instructions given here:

https://bugzilla.redhat.com/show_bug.cgi?id=476818 (-> Comment #12)

with the following packages:
nash-6.0.71-4.fc10.x86_64
dmraid-1.0.0.rc15-6.fc11.x86_64
device-mapper-1.02.30-1.fc11.x86_64
device-mapper-libs-1.02.27-7.fc10.i386
device-mapper-libs-1.02.30-1.fc11.x86_64
mkinitrd-6.0.71-4.fc10.x86_64


The kernel boots and recognizes the raid. But I get horrible filesystem errors, and can't even log in. Rebooting into the working fc9 kernel then shows, that the filesystem has been damaged by this experiment.

But I get much farther than before. 

Any ideas?
Comment 16 Hans de Goede 2009-03-08 04:19:53 EDT
Hi All,

dmraid support in anaconda / mkinitrd unfortunately is not in a good shape in F-10 (nor in F-11 alpha). I've been working very hard lately to fix this, and F-11 will be much better!

There are a number of underlying causes to these problems, all of which have been identified and fixed in rawhide I believe.

Unfortunately rawhide is currently not in a good shape to ask you to test it. We hope to organize a dmraid test day, within 2 weeks, where we will ask the community to test dmraid support in rawhide (the upcoming F-11 development version).

In the mean time I'm closing all the open anaconda dmraid bugs, against a single master bug, for easier tracking, as all the open bugs have the same underlying cause (2 bugs in pyblock, which have been fixed).

If you're interested in participating in the test day, please add yourself to the CC of the master bug, I will add a comment there with a pointer to the announcement for the test day as soon as the date has been fixed.

*** This bug has been marked as a duplicate of bug 489148 ***