Bug 475003 - No libata and ata_piix modules provided with the 2.6.27.5-117.f10 kernel
No libata and ata_piix modules provided with the 2.6.27.5-117.f10 kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 10:49 EST by Dmitry Burstein
Modified: 2008-12-08 13:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 13:39:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Burstein 2008-12-06 10:49:52 EST
Description of problem:
The lack of ata_piix and related modules in the distribution's default kernel caused Intel-based (ICH5 etc.) sata RAID to be unrecognised. This made it impossible to install or run F10 on ICH?R-based systems!

Version-Release number of selected component (if applicable):
2.6.27.5-117.f10.i686

Additional info:
also in rawhide 2.6.27.7-130.fc10.i686

This is probably the reason for the Bug #471737 and many other related bugs.
Comment 1 Dmitry Burstein 2008-12-07 17:25:53 EST
Yet still in the rawhide 2.6.27.7-134.fc10.i686
Comment 2 Chuck Ebbert 2008-12-08 13:39:02 EST
They are built into the kernel.

config-generic:CONFIG_ATA=y
config-generic:CONFIG_ATA_SFF=y
config-generic:CONFIG_ATA_PIIX=y
config-generic:CONFIG_ATA_ACPI=y
config-generic:CONFIG_SATA_AHCI=y

Note You need to log in before you can comment on or make changes to this bug.