This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes

Bug 472905

Summary: Preupgrade hang+traceback going from F-9 to Rawhide (day before F10 release)
Product: [Fedora] Fedora Reporter: Casey Dahlin <cdahlin>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: vanhoof, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-26 16:31:08 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Casey Dahlin 2008-11-25 10:38:10 EST
The day before the F10 release I ran preupgrade. It got to the Download boot images phase and hung on Downloading installer metadata.

The terminal I ran it from contained this:

Loaded plugins: refresh-packagekit
No package matched to remove
Traceback (most recent call last):
  File "/usr/share/preupgrade/", line 198, in on_assistant_apply
  File "/usr/share/preupgrade/", line 206, in _do_main
  File "/usr/share/preupgrade/", line 349, in main_preupgrade
  File "/usr/lib/python2.5/site-packages/preupgrade/", line 395, in retrieve_treeinfo
    self.instimage = cp.get('stage2', 'instimage')
  File "/usr/lib64/python2.5/", line 520, in get
    raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'instimage' in section: 'stage2'

It got here just before I left work yesterday, so it hasn't moved in at least 16 hours.
Comment 1 Will Woods 2008-11-26 16:31:08 EST
You need to update to preupgrade-1.0.0.

*** This bug has been marked as a duplicate of bug 459935 ***