Bug 472905 - Preupgrade hang+traceback going from F-9 to Rawhide (day before F10 release)
Preupgrade hang+traceback going from F-9 to Rawhide (day before F10 release)
Status: CLOSED DUPLICATE of bug 459935
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 10:38 EST by Casey Dahlin
Modified: 2014-06-18 04:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 16:31:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Casey Dahlin 2008-11-25 10:38:10 EST
The day before the F10 release I ran preupgrade. It got to the Download boot images phase and hung on Downloading installer metadata.

The terminal I ran it from contained this:

Loaded plugins: refresh-packagekit
No package matched to remove
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 198, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 206, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 349, in main_preupgrade
    self.pu.retrieve_treeinfo()
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 395, in retrieve_treeinfo
    self.instimage = cp.get('stage2', 'instimage')
  File "/usr/lib64/python2.5/ConfigParser.py", line 520, in get
    raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'instimage' in section: 'stage2'

It got here just before I left work yesterday, so it hasn't moved in at least 16 hours.
Comment 1 Will Woods 2008-11-26 16:31:08 EST
You need to update to preupgrade-1.0.0.

*** This bug has been marked as a duplicate of bug 459935 ***

Note You need to log in before you can comment on or make changes to this bug.