Bug 474084

Summary: FC10 install fails resolving dependancies
Product: [Fedora] Fedora Reporter: Chris Elmquist <chrise>
Component: yumAssignee: Seth Vidal <skvidal>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: ffesti, james.antill, katzj, pmatilai, tla
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: anaconda_trace_hash:a5ec0c1829b040467d8108b579335709c377746a6a39c726bf9aa91a53a4dc82
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-01-14 15:31:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Attached traceback automatically from anaconda. none

Description Chris Elmquist 2008-12-02 02:44:36 UTC
This bug was filed automatically by anaconda.

Comment 1 Chris Elmquist 2008-12-02 02:44:41 UTC
Created attachment 325326 [details]
Attached traceback automatically from anaconda.

Comment 2 Chris Elmquist 2008-12-02 03:16:35 UTC
Numerous attempts to install FC10 on this system always result
in this failure from anaconda.  I have tried directly from
DVD .iso, from network .iso, network via URL to a mirror site,
blows up the same way every time.

This system was previously running FC9 without issue.  I tried to
upgrade and that resulted in hangs, lockups and finally the inability
to complete the install due to a missing dblib of some sort which
RPM and yum needed to finish the install.

So, I have gone back to trying to install FC10 fresh-- wiped
the disk-- yet I continue to encounter these python dumps from
anaconda.

Very frusterating.  This is not what I have come to expect from the
Fedora project.

Comment 3 James Antill 2008-12-02 16:22:08 UTC
Traceback (most recent call first):
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 237, in returnPrco
    if isinstance(self.prco[prcotype], tuple):
[...]
TypeError: _share_data() takes exactly 1 argument (2 given)

...awesome, not only is _share_data() not called on that line, but AFAICS it isn't called with two arguments anywhere in that file.
 Did you check the media?