Bug 480425
| Summary: | Package requires python-sqlite2 even with python2.5 w/native support for sqlite | ||
|---|---|---|---|
| Product: | [Fedora] Fedora | Reporter: | Matěj Cepl <mcepl> |
| Component: | jabbim | Assignee: | Michal Schmidt <mschmidt> |
| Status: | CLOSED RAWHIDE | QA Contact: | Fedora Extras Quality Assurance <extras-qa> |
| Severity: | medium | Docs Contact: | |
| Priority: | low | ||
| Version: | 10 | CC: | mcepl, mschmidt |
| Target Milestone: | --- | ||
| Target Release: | --- | ||
| Hardware: | All | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2009-01-17 07:12:48 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
|
Description
Matěj Cepl
2009-01-16 23:27:04 UTC
Thanks, I didn't know Python 2.5 already had sqlite support integrated. Looking at Jabbim source, I can see it does the right thing - it tries sqlite3 first and only if that is not available it falls back to pysqlite2. So the "Requires" can be safely removed. I'll fix it. Fixed in jabbim-0.4.3-5. I'm not going to request updates just for this change. |