Bug 480425 - Package requires python-sqlite2 even with python2.5 w/native support for sqlite
Package requires python-sqlite2 even with python2.5 w/native support for sqlite
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jabbim (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Michal Schmidt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 18:27 EST by Matěj Cepl
Modified: 2009-01-17 02:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-17 02:12:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2009-01-16 18:27:04 EST
Description of problem:
Python 2.5 contains native support for sqlite. Could you please recheck that you really cannot use that for your package instead of depending on python-sqlite2?

Thank you

Version-Release number of selected component (if applicable):
jabbim-0.4.3-3.fc10.noarch

How reproducible:
100%

Steps to Reproduce:
1.rpm -qR jabbim |grep sqlite
2.
3.
  
Actual results:
python-sqlite2

Expected results:
nothing

Additional info:
Comment 1 Michal Schmidt 2009-01-17 01:34:22 EST
Thanks, I didn't know Python 2.5 already had sqlite support integrated.
Looking at Jabbim source, I can see it does the right thing - it tries sqlite3 first and only if that is not available it falls back to pysqlite2. So the "Requires" can be safely removed. I'll fix it.
Comment 2 Michal Schmidt 2009-01-17 02:12:48 EST
Fixed in jabbim-0.4.3-5.
I'm not going to request updates just for this change.

Note You need to log in before you can comment on or make changes to this bug.