Bug 486501

Summary: html output does not display correctly in IE7
Product: [Community] Publican Reporter: Darrin Mison <dmison>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED CURRENTRELEASE QA Contact: Content Services Development <ecs-dev-list>
Severity: medium Docs Contact:
Priority: low    
Version: 2.0CC: alex.aycinena, mmcallis, publican-list
Target Milestone: ---Keywords: Documentation
Target Release: ---   
Hardware: All   
OS: Linux   
URL: https://jira.jboss.org/jira/browse/SOA-1179
Whiteboard:
Fixed In Version: 0.43 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-02-23 22:44:40 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
screenshot as per jira SOA-1179 none

Description Darrin Mison 2009-02-19 20:52:52 EST
Description of problem:
Internet Explorer users cannot use the html documentation that is generated by publican.

The object tag that is required for all non-IE browsers to display SVG seems to cause IE to break the entire page.  If you use <img>it still renders as a broken image because the format is not supported but doesn't break the whole page.  

<object data="Common_Content/images/redhat-logo.svg" type="image/svg+xml"/> 

This means that page breaks immediately after the subtitle and is not usable.

A JBoss JIRA was raised, https://jira.jboss.org/jira/browse/SOA-1179 , to report this.

Because SVG content does not display natively in Internet Explorer anyway perhaps we should convert the SVG to png and display via <img>


Version-Release number of selected component (if applicable):
publican 0.42

How reproducible:
everytime

Steps to Reproduce:
1.attempt to view publican generated html docs in Internet Explorer 7
eg. http://www.redhat.com/docs/en-US/JBoss_SOA_Platform/4.3.GA/html-single/Programmers_Guide/index.html

Actual results:
screenshot  from JIRA attached

Expected results:


Additional info:
Comment 1 Darrin Mison 2009-02-19 22:56:54 EST
Created attachment 332666 [details]
screenshot as per jira SOA-1179
Comment 2 Jeff Fearn 2009-02-20 18:32:49 EST
Possible fix is to modify the XSL that generates the object tags to output:

<object data="Common_Content/images/title_logo.svg" type="image/svg+xml">
	<img src="Common_Content/images/title_logo.png" alt="Alternate image for broken browsers"> 
</object>

This should allow non-compliant browsers to fall back to a png image.

Hope to get to test this next week.
Comment 3 Jeff Fearn 2009-02-23 22:44:40 EST
I modified the SQL so that browsers that can not display the SVG will display the text object used for the ALT text. Tested OK in IE 7.

This solution will mean most existing books do not need to be modified to display in IE7.
Comment 4 Fedora Update System 2009-03-18 19:57:13 EDT
publican-fedora-0.18-0.fc10,publican-0.44-0.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/publican-fedora-0.18-0.fc10,publican-0.44-0.fc10
Comment 5 Fedora Update System 2009-03-26 10:53:22 EDT
publican-fedora-0.18-0.fc10, publican-0.44-0.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Ruediger Landmann 2009-10-05 19:19:14 EDT
*** Bug 512471 has been marked as a duplicate of this bug. ***