Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.

Bug 487193

Summary: gnome-mount has hardcoded Requires: PolicyKit-gnome
Product: [Fedora] Fedora Reporter: Kevin Kofler <kevin>
Component: gnome-mountAssignee: David Zeuthen <davidz>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: high    
Version: rawhideCC: davidz, mclasen
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-02-27 09:25:42 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 446451, 487188    

Description Kevin Kofler 2009-02-24 13:04:47 EST
Description of problem:
gnome-mount has a hardcoded dependency on PolicyKit-gnome. Is this really necessary? In the KDE spin, we would like to ship PolicyKit-kde instead of PolicyKit-gnome. PolicyKit-kde also implements the org.freedesktop.PolicyKit.AuthenticationAgent service.

(gnome-mount is included on the current KDE spin.)

Version-Release number of selected component (if applicable):
gnome-mount-0:0.8-3.fc11

How reproducible:
Always

Steps to Reproduce:
1. repoquery --repoid=rawhide --whatrequires PolicyKit-gnome
  
Actual results:
gnome-mount requires PolicyKit-gnome.

Expected results:
gnome-mount does not require PolicyKit-gnome.

Additional info:
Maybe a common Provides in both PolicyKit-gnome and PolicyKit-kde is needed?
Comment 1 Kevin Kofler 2009-02-24 13:14:45 EST
gnome-mount and system-config-services are the packages actually dragging PolicyKit-gnome onto the KDE spin.
Comment 2 Matthias Clasen 2009-02-27 09:25:42 EST
Changed to require PolicyKit-authentication-agent