Bug 487188 - (Req-PolicyKit-gnome) Tracker bug for hardcoded Requires: PolicyKit-gnome
Tracker bug for hardcoded Requires: PolicyKit-gnome
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PolicyKit-gnome (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On: 487190 487191 487193 487194 487195 487200
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 12:54 EST by Kevin Kofler
Modified: 2009-03-04 18:46 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 18:46:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2009-02-24 12:54:29 EST
Description of problem:
Several packages have a hardcoded dependency on PolicyKit-gnome. Is this really necessary? In the KDE spin, we would like to ship PolicyKit-kde instead of PolicyKit-gnome. This tracker bug will be used to track these dependencies.
Comment 1 Matthias Clasen 2009-02-25 12:07:40 EST
To answer the question: no, it should not be necessary.
We would accept patches to add some silly

Provides: PolicyKit-authentication-agent

and then change all the packages to require that.

FWIW, this problem will disappear in early F12 with PolicyKit 1.0, when the responsibility for launching a suitable authentication agent will move to the session.
Comment 2 Matthias Clasen 2009-02-27 02:09:48 EST
I've added

Provides: PolicyKit-authentication-agent

to PolicyKit-gnome now. I'll fix up the various requires tomorrow.
Comment 3 Kevin Kofler 2009-02-27 12:15:01 EST
Also added to PolicyKit-kde-4.2.0-3.fc11.
Comment 4 Kevin Kofler 2009-03-04 18:46:06 EST
Looks like this is now sorted out everywhere, thanks.

Note You need to log in before you can comment on or make changes to this bug.