Bug 492075

Summary: qemu package missing debuginfo for qemu-img
Product: [Fedora] Fedora Reporter: Mark McLoughlin <markmc>
Component: qemuAssignee: Glauber Costa <gcosta>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: high    
Version: rawhideCC: dwmw2, gcosta, markmc, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-02 09:00:27 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 480593    

Description Mark McLoughlin 2009-03-25 05:44:30 EDT
See also bug #491943

qemu-debuginfo-0.10-0.11.kvm20090323git.fc11 appears to be missing debuginfo for qemu-img
Comment 1 Glauber Costa 2009-03-25 09:46:05 EDT
At least it is not a regression from the new package.

I took a look at it, and debuginfo for qemu-img was already missing in F10
Still not sure why, tracking it down.
Comment 2 Mark McLoughlin 2009-03-25 15:13:40 EDT
Glauber's patch with wonderfully eloquent changelog:

  http://marc.info/?l=qemu-devel&m=123800655221045

  install -s is pretty and cute, but makes the binary get into the build
  directory without any debug information. This is bad, and makes glommer
  sad.
Comment 3 Glauber Costa 2009-04-02 08:59:49 EDT
[glauber@poweredge Download]$ rpm -qlp qemu-debuginfo-0.10-4.fc11.x86_64.rpm  | grep img
/usr/lib/debug/usr/bin/qemu-img.debug
/usr/src/debug/qemu-kvm-0.10/qemu/qemu-img.c

I'm closing it in rawhide.