Bug 492075 - qemu package missing debuginfo for qemu-img
qemu package missing debuginfo for qemu-img
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtBlocker
  Show dependency treegraph
 
Reported: 2009-03-25 05:44 EDT by Mark McLoughlin
Modified: 2009-04-02 09:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 09:00:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-03-25 05:44:30 EDT
See also bug #491943

qemu-debuginfo-0.10-0.11.kvm20090323git.fc11 appears to be missing debuginfo for qemu-img
Comment 1 Glauber Costa 2009-03-25 09:46:05 EDT
At least it is not a regression from the new package.

I took a look at it, and debuginfo for qemu-img was already missing in F10
Still not sure why, tracking it down.
Comment 2 Mark McLoughlin 2009-03-25 15:13:40 EDT
Glauber's patch with wonderfully eloquent changelog:

  http://marc.info/?l=qemu-devel&m=123800655221045

  install -s is pretty and cute, but makes the binary get into the build
  directory without any debug information. This is bad, and makes glommer
  sad.
Comment 3 Glauber Costa 2009-04-02 08:59:49 EDT
[glauber@poweredge Download]$ rpm -qlp qemu-debuginfo-0.10-4.fc11.x86_64.rpm  | grep img
/usr/lib/debug/usr/bin/qemu-img.debug
/usr/src/debug/qemu-kvm-0.10/qemu/qemu-img.c

I'm closing it in rawhide.

Note You need to log in before you can comment on or make changes to this bug.