Bug 493307

Summary: DRM not enabled for Intel G41 chipsets
Product: [Fedora] Fedora Reporter: Jonathan Dieter <jdieter>
Component: kernelAssignee: Kristian Høgsberg <krh>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: high    
Version: 10CC: airlied, kernel-maint, rodd, tgrondin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-07-30 05:34:02 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Patch that enables DRM for Intel G41 in 2.6.27 kernel none

Description Jonathan Dieter 2009-04-01 07:12:45 EDT
Description of problem:
DRM is not enabled for G41 chipsets

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.27.19-170.2.35.fc10.i686
kernel-PAE-2.6.27.21-170.2.56.fc10.i686

How reproducible:
Always

Steps to Reproduce:
1. Boot computer
2. Start X
  
Actual results:
No 3D Graphics (and X freezes, but that's some other error)

Expected results:
3D Graphics (and X working)

Additional info:
When I compile 2.6.27.19-170.2.35 with the following patch added at the end, X works with 3D and compiz enabled.  I don't know why this patch hasn't made it into the mainline kernel.  I found the patch at:
http://www.mail-archive.com/dri-devel@lists.sourceforge.net/msg36886.html
and made a small modification to fit the Fedora kernel
Comment 1 Jonathan Dieter 2009-04-01 07:14:38 EDT
Created attachment 337490 [details]
Patch that enables DRM for Intel G41 in 2.6.27 kernel
Comment 2 Chuck Ebbert 2009-04-01 11:11:53 EDT
Huh, I can't find this patch anywhere upstream, not even in drm-next in the Fedora rawhide tree...
Comment 3 Jonathan Dieter 2009-04-08 02:30:18 EDT
Is there anything you'd like me to do to help this along?
Comment 4 Kristian Høgsberg 2009-04-09 09:51:52 EDT
Not supported upstream yet, bug here:

  https://bugzilla.redhat.com/show_bug.cgi?id=493307

The chipset has known problems.
Comment 5 Jonathan Dieter 2009-04-09 10:04:28 EDT
(In reply to comment #4)
> Not supported upstream yet, bug here:
> 
>   https://bugzilla.redhat.com/show_bug.cgi?id=493307

Which is a link back to this bug.  Typo or am I missing something?

> The chipset has known problems.  

FWIW, it seems to be working as reliably as the G31 and G35 chipsets for us using F10 (as long as DRM is enabled).

We're running 40 F10 computers in a lab with the G965, G31, G35 and G41 chipsets.  If there's anything we can do to help troubleshoot or resolve this, please let me know.
Comment 6 Kristian Høgsberg 2009-04-09 10:33:52 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > Not supported upstream yet, bug here:
> > 
> >   https://bugzilla.redhat.com/show_bug.cgi?id=493307
> 
> Which is a link back to this bug.  Typo or am I missing something?
> 
> > The chipset has known problems.  
> 
> FWIW, it seems to be working as reliably as the G31 and G35 chipsets for us
> using F10 (as long as DRM is enabled).
> 
> We're running 40 F10 computers in a lab with the G965, G31, G35 and G41
> chipsets.  If there's anything we can do to help troubleshoot or resolve this,
> please let me know.  

Eek, thanks.  Here's the right upstream URL:

  http://bugs.freedesktop.org/show_bug.cgi?id=21095

We don't have a G41 here and the intel guys says that the one system they've tried had a memory problem (too much stolen memory afaik).  That may be a problem with the specific system they had or the chipset in general.  I suggest posting details of you setup and experiments with enabling the G41 in the upstream bug.

thanks,
Kristian
Comment 7 Rodd Clarkson 2009-05-01 07:48:17 EDT
It looks like a patch has been added to 2.6.30-rc4 mainline (according to the freedesktop bugzilla and it seems that someone recently built kernel-2.6.30-0.76.rc4.fc12 which is clearly for f12, but might be worth trying (read I'm trying it tomorrow some time)

http://koji.fedoraproject.org/koji/packageinfo?packageID=8
http://koji.fedoraproject.org/koji/buildinfo?buildID=100421

Thought the heads up was worth it.
Comment 8 Timothy Grondin 2009-05-01 14:52:29 EDT
I can confirm that with kernel 2.6.30-rc4.fc12.586 hardware acceleration is working properly on this chip set. 

Compiz, textured video and dri2 are all working perfectly. 

Can we have this patch pushed into a fedora 11 kernel?
Comment 9 Rodd Clarkson 2009-05-03 00:17:27 EDT
I've tried the above kernel, but it doesn't finish booting (with I think some PCI kernel issues)

Is there any chance of rolling this into a koji f11 kernel build to test?
Comment 10 Rodd Clarkson 2009-05-03 00:19:22 EDT
*** Bug 487619 has been marked as a duplicate of this bug. ***
Comment 11 Rodd Clarkson 2009-05-08 02:21:39 EDT
I'm having troubles using any of the kernels with this patch.  I've filed a separate bug as it may not be Intel G41 DRM related.  I'm mentioning it here as I suspect it is.

https://bugzilla.redhat.com/show_bug.cgi?id=499779
Comment 12 Kristian Høgsberg 2009-05-08 09:30:13 EDT
Have anybody else tried the kernels with G41 support?  Either try an F-12 kernel or get this F-11 build:

  http://koji.fedoraproject.org/koji/buildinfo?buildID=101268

thanks
Comment 13 Timothy Grondin 2009-05-08 16:06:05 EDT
I tired it with the F-11 build and it works fine after boot up. The fancy boot screens do not work properly, but everything else is just fine. 

The 2.6.30* kernels also work at least for me. 

Lspci is showing:

00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
Comment 14 Jonathan Dieter 2009-05-12 01:19:19 EDT
I've upgraded one of my G41's to Rawhide, installed the kernel, and it works great (better than the G31 that's running an identical install, actually) except for one minor issue: Warzone doesn't work.  The startup screen is fine, but once you start playing, none of the 3D stuff is rendered.

Tuxcart (fullscreen), Glest (fullscreen) and Neverputt (windowed) all work completely correctly.
Comment 15 Chuck Ebbert 2009-05-20 21:14:02 EDT
Support added in 2.6.27.24-170.2.61 and later F10 kernels.