Bug 487619 - Intel 4 Series Chipset Intergrated Graphics (rev 03) not working with intel drivers
Intel 4 Series Chipset Intergrated Graphics (rev 03) not working with intel d...
Status: CLOSED DUPLICATE of bug 493307
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
10
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 21:52 EST by Rodd Clarkson
Modified: 2009-05-04 09:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-03 00:19:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log file when using VGA output (20.84 KB, text/plain)
2009-02-26 21:52 EST, Rodd Clarkson
no flags Details
Xorg.0.log file when using HDMI (Digital) output (18.81 KB, text/plain)
2009-02-26 21:54 EST, Rodd Clarkson
no flags Details
output from lspci (1.61 KB, text/plain)
2009-02-26 21:55 EST, Rodd Clarkson
no flags Details
output from lspci -vv (12.24 KB, text/plain)
2009-02-26 21:56 EST, Rodd Clarkson
no flags Details
Xorg.0.log file after changing bios to PAVP Paranoid mode (54.61 KB, text/plain)
2009-02-28 06:10 EST, Rodd Clarkson
no flags Details
my X log with an homebrewed 2.6.29-rc6 kernel (96.64 KB, text/plain)
2009-02-28 15:48 EST, Ronald Warsow
no flags Details
my X log with an homebrewed 2.6.29-rc6 kernel (96.64 KB, text/plain)
2009-02-28 15:54 EST, Ronald Warsow
no flags Details
dmesg output (29.17 KB, text/plain)
2009-02-28 21:45 EST, Rodd Clarkson
no flags Details
Xorg.0.log file after enabling 'xaa' in xorg.conf and running startx as root (70.22 KB, text/plain)
2009-02-28 21:53 EST, Rodd Clarkson
no flags Details
Xorg.0.log file after enabling 'xaa' in xorg.conf and running startx as a statndard user (84.85 KB, text/plain)
2009-02-28 21:54 EST, Rodd Clarkson
no flags Details
my dmesg with an 2.6.27.15-170.2.24.fc10.i686 kernel (36.47 KB, text/plain)
2009-02-28 22:17 EST, Ronald Warsow
no flags Details
Xorg.0.log file with no xorg.conf file (using rawhide) (6.23 KB, text/plain)
2009-03-05 18:44 EST, Rodd Clarkson
no flags Details
dmesg output (using rawhide) (33.67 KB, text/plain)
2009-03-05 18:45 EST, Rodd Clarkson
no flags Details
Xorg.0.log file with very limited xorg.conf file to require 'intel' driver (using rawhide) (41.47 KB, text/plain)
2009-03-05 18:46 EST, Rodd Clarkson
no flags Details
Xorg.0.log file with no xorg.conf file (using rawhide) 20090307 (47.15 KB, text/plain)
2009-03-07 18:25 EST, Rodd Clarkson
no flags Details

  None (edit)
Description Rodd Clarkson 2009-02-26 21:52:57 EST
Created attachment 333427 [details]
Xorg.0.log file when using VGA output

Description of problem:

When I try to `startx 2&> /tmp/start.output` using the 'intel' driver I get the following output:

xauth:  creating new authority file /home/mythtv/.serverauth.3505


X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-92.1.18.el5 i686 
Current Operating System: Linux mythtv 2.6.27.15-170.2.24.fc10.i686 #1 SMP Wed Feb 11 23:58:12 EST 2009 i686
Build Date: 11 December 2008  05:27:37PM
Build ID: xorg-x11-server 1.5.3-6.fc10 
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Feb 27 13:45:31 2009
(==) Using config file: "/etc/X11/xorg.conf"
(EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)
(EE) [drm] drmOpen failed.
(EE) intel(0): [dri] DRIScreenInit failed. Disabling DRI.
(EE) intel(0): Couldn't allocate video memory

Fatal server error:
AddScreen/ScreenInit failed for driver 0

giving up.
xinit:  No such file or directory (errno 2):  unable to connect to X server
xinit:  No such process (errno 3):  unexpected signal 2.


Version-Release number of selected component (if applicable):

It's an up-to-date f10 box with all the lasted drivers.

The xorg.conf file is as follows:


# Xorg configuration created by system-config-display

Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
EndSection


(Obviously, s-c-d didn't create this).


I'll attach a selection of log files and the likes to help diagnose.
Comment 1 Rodd Clarkson 2009-02-26 21:54:14 EST
Created attachment 333429 [details]
Xorg.0.log file when using HDMI (Digital) output
Comment 2 Rodd Clarkson 2009-02-26 21:55:25 EST
Created attachment 333430 [details]
output from lspci
Comment 3 Rodd Clarkson 2009-02-26 21:56:10 EST
Created attachment 333431 [details]
output from lspci -vv
Comment 4 Ben Boeckel 2009-02-27 23:08:20 EST
I'm going to guess that the Xorg.conf isn't complete. Try it without one. I have an Intex GMA X4500HD and it works fine without a Xorg.conf.

I'm guessing part of the error is this:
(EE) GARTInit: Unable to open /dev/agpgart (No such file or directory)

I'm no X expert, but since the board doesn't have AGP, when X looks for it, it dies. Not the best behavior, so it may be a bug in X, not the intel driver.
Comment 5 Rodd Clarkson 2009-02-27 23:24:02 EST
Okay, I've tried running without and xorg.conf file and it still doesn't work.  I'll post the Xorg.0.log file is it's wanted, but it's essentially the same, except it spews out some stuff about no config and creates one on the fly.  Same error still
Comment 6 Rodd Clarkson 2009-02-28 06:07:32 EST
Okay, I've made some headway.

It turns out my motherboards bios (it's a Gigabyte GA-EG41MS2H) has some
settings in it's advanced chipset features about PAVP.

PAVP comes set in Lite Mode with 32MB of memory.

If I change this to Paranoid PAVP (and I've set the memory set aside to 256MB)
then all of a sudden this problem changes and I think I'm not dealing with
something new.

X now starts in what seems to be the correct resolution, but it then freezes
with no input from the keyboard, but the mouse still moves the cursor.

One of the Xorg.0.log files I read early after this change said something about
an infinite loop, but every log file since seems to stop part way through the
logging process.  I'll attach a log for you to log at.
Comment 7 Rodd Clarkson 2009-02-28 06:10:21 EST
Created attachment 333599 [details]
Xorg.0.log file after changing bios to PAVP Paranoid mode
Comment 8 Ronald Warsow 2009-02-28 15:46:23 EST
maybe some hints to compare...

my board is with an Intel GMA X4500HD.

http://www.gigabyte.com.tw/Products/Motherboard/Products_Overview.aspx?ProductID=2877

me thinks a successor of yours.


I have no xorg.conf, nor special bios setting and have no problems with F10 or F11 so far.


ll /dev/agpgart 
crw------- 1 root root 10, 175 2009-02-28 21:15 /dev/agpgart

see comment #4

dmesg|grep -i agp
Linux agpgart interface v0.103
agpgart-intel 0000:00:00.0: Intel G45/G43 Chipset
agpgart-intel 0000:00:00.0: detected 131068K stolen memory
agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000


cat /var/log/Xorg.0.log |grep -i agp
(II) intel(0): [drm] Initialized kernel agp heap manager, 33554432


PAVP (what ever it is for) has no influence of a working X.
Comment 9 Ronald Warsow 2009-02-28 15:48:01 EST
Created attachment 333618 [details]
my X log with an homebrewed 2.6.29-rc6 kernel
Comment 10 Ronald Warsow 2009-02-28 15:54:39 EST
Created attachment 333619 [details]
my X log with an homebrewed 2.6.29-rc6 kernel
Comment 11 François Cami 2009-02-28 17:42:07 EST
Rodd,

Could you attach dmesg as well ?
Could you check you are using the latest BIOS ?
Is there anything ressembling GART size, or memory
size for integrated video, in BIOS ?

Thank you

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Rodd Clarkson 2009-02-28 21:45:11 EST
Created attachment 333629 [details]
dmesg output
Comment 13 Rodd Clarkson 2009-02-28 21:52:26 EST
I've tried enabling 'xaa' by adding it to the small xorg.conf file I'm using.

Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
        Option "AccelMethod" "XAA"
EndSection

and xorg seems to go future.  I've run it once as root and I actually got to ask the system to poweroff (using the GUI) but something hung during shutdown.

and I've run it one as a user and the desktop partially loaded before it locked.

I'll attach both the Xorg.0.log files for these two attempts.
Comment 14 Rodd Clarkson 2009-02-28 21:53:52 EST
Created attachment 333630 [details]
Xorg.0.log file after enabling 'xaa' in xorg.conf and running startx as root
Comment 15 Rodd Clarkson 2009-02-28 21:54:42 EST
Created attachment 333631 [details]
Xorg.0.log file after enabling 'xaa' in xorg.conf and running startx as a statndard user
Comment 16 Ronald Warsow 2009-02-28 22:17:22 EST
Created attachment 333632 [details]
my dmesg with an 2.6.27.15-170.2.24.fc10.i686 kernel

maybe it's helpfull
Comment 17 Rodd Clarkson 2009-02-28 22:20:27 EST
I've just changed to the BIOS to use PAVP in lite mode, instead of in Paranoid
mode and I've set up PAVP Lite to use 256MB memory, instead of the 32 its comes
configured to use by default.  xorg works like this.

I've also changed the monitor from the DVI-D (or what I've been calling the
digital) port to the D-Sub (or what I've been calling the analogue port) and
now xorg seems to work without issue (well, so far at least).

I can now log in, log out and do stuff in the middle.  I'm currently letting it
run mythtv for a while to see how things go.

1. So PAVP mode settings don't seem important.
2. Assigning more than 32MB of memory does (and maybe this is something that
xorg should be aware of.  It occurs to me that 32MB probably isn't anywhere
near enough to run 1680x1050x32Bit)
3. Using the D-Sub works, but DVI-D seems to have issues.  The mother board
documentation seems to suggest that they are slightly different interfaces and
the DVI-D is linked to the HDMI output (but I don't have a HDMI cabable screen
to test this with).

What else would you like to know?
Comment 18 Rodd Clarkson 2009-02-28 22:27:39 EST
Also, two questions regarding the driver package.

There's a xorg-x11-drv-i810-2.5.0-5.fc10 build in koji.  It this worth trying, or won't it make any difference?

Also, intel has released 2.6.0 and I noticed that this has been built for f11.  Can this be back-ported to f10 (even if just in koji) for testing?
Comment 19 François Cami 2009-03-01 04:38:55 EST
Please add dmesg and Xorg.0.log of a working attempt for comparison
purposes. You can try the build in Koji as well.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Rodd Clarkson 2009-03-01 06:24:09 EST
Right, I might have got a little carried away.  While it's true that I did manage to get x working and that I can confirm it worked for at least 10 minutes, it locked up at some point after that and then my attempt to reboot saw x locking up before the desktop had even loaded, so while things are better, they are by no means useable and I'm not sure that the dmesg I post now would be any different to the dmesg I've already posted.  I'll see if I can get into an x session and out tomorrow and then post that xorg.0.log file.
Comment 21 Rodd Clarkson 2009-03-05 18:43:34 EST
Okay, I've installed rawhide to try and see what difference there are.

Install went fine.  the x in the installer ran fine and had no issues.

First start starts and and you can step through that, but the x restart after first start sees x no longer working (strange).

After running firstboot and then powering off and restarting firstboot started again.  I managed to get inittab set to runlevel 3 (which is kind of important when trying to figure out what's wrong with x and having to reboot all the time)

I then ran yum update and am now current.

There's initially no X configuration and X doesn't work.  Strangle, it seems it doesn't try to load either i810 or intel as drivers.

I then added a very basic xorg.conf file to set the driver as intel.  Now X seems to work at some level, but switching to compiz sees a white screen until it times out and then works again.

I'll attach relevant log files and dmesg for this box.
Comment 22 Rodd Clarkson 2009-03-05 18:44:24 EST
Created attachment 334238 [details]
Xorg.0.log file with no xorg.conf file (using rawhide)
Comment 23 Rodd Clarkson 2009-03-05 18:45:03 EST
Created attachment 334239 [details]
dmesg output (using rawhide)
Comment 24 Rodd Clarkson 2009-03-05 18:46:05 EST
Created attachment 334240 [details]
Xorg.0.log file with very limited xorg.conf file to require 'intel' driver (using rawhide)
Comment 25 Rodd Clarkson 2009-03-05 18:46:58 EST
All of this testing using rawhide is using the DVI-D connection.  If you want, I'll try D-SUB too.
Comment 26 Rodd Clarkson 2009-03-07 17:07:39 EST
Okay, I've tried D-SUB and while x starts a little differently it still doesn't start compiz correctly.

When you try to run Desktop Effects, the screen goes white (but moving the mouse around sees the pointer change presumably as it moves over different elements on the screen).  If you wait, it automatically times out desktop effects.
Comment 27 Rodd Clarkson 2009-03-07 17:19:05 EST
I'm currently using:

xorg-x11-drv-intel-2.6.0-14.fc11.i586
xorg-x11-server-utils-7.4-7.fc11.i586
xorg-x11-server-common-1.6.0-9.fc11.i586
xorg-x11-server-Xorg-1.6.0-9.fc11.i586
compiz-0.7.8-14.fc11.i586
kernel-2.6.29-0.207.rc7.fc11.i586
Comment 28 Rodd Clarkson 2009-03-07 18:18:11 EST
Oaky, I've just tested without an xorg.conf file (in rawhide) and X now recognized that the intel driver exists (along with the i810 driver) and it appears it is using it.

This is a vaste improvement on f10 but there are still a few annoying things.

1. compiz doesn't appear to work out of the box. (as mentioned above).  Maybe it is possible to throw some setting in xorg.conf, but what I don't know (and haven't tried anything)

2. x doesn't seem to kill too well.  if I start in run level 5 and then switch to a terminal, log in as root and run `init 3` it appears to work, but switching to vt1 (or vt7) sees the display go blank and while the keyboard still works, you have to reboot to get the monitor showing something again.

3. I'm not sure if I'm talking to myself, or if someone is actually interested in any of this.  I haven't seen a single input from any staff from redhat (according to email address/logins above) and I would had thought a few prompts of what to try wouldn't be out of the question.
Comment 29 Rodd Clarkson 2009-03-07 18:25:17 EST
Created attachment 334428 [details]
Xorg.0.log file with no xorg.conf file (using rawhide) 20090307
Comment 30 Ronald Warsow 2009-03-07 19:17:47 EST
maybe to 2. see my grub.conf

currently don't how the orginal grub.conf looks like, but see parameter's:
- vga=0x318
- none rhgb quiet

X is on VT1 (CRTL+ALT+F1) not VT7
means switching X <=> VTn works with this grub.conf 

to 1.
compiz works with my homebrewed 2.6.29.rc7 kernel


cat /boot/grub/grub.conf 

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VG_OS/root
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
#	hiddenmenu
#  	kernel ... rhgb quiet  console=tty0 console=tty1 console=ttyS0,115200n8 selinux=0 audit=0 vga=0x318 
#	acpi.debug_layer=0xffffffff acpi.debug_level=0xfff 
#
title Fedora (2.6.29-rc7_0-00003-g559595a)
	root (hd0,0)
	kernel /vmlinuz-2.6.29-rc7_0-00003-g559595a ro root=/dev/VG_OS/root audit=0 selinux=0 vga=0x318 
	initrd /initrd-2.6.29-rc7_0-00003-g559595a.img

title Fedora (2.6.27.19-170.2.35.fc10.i686)
	root (hd0,0)
	kernel /vmlinuz-2.6.27.19-170.2.35.fc10.i686 ro root=/dev/VG_OS/root audit=0 selinux=0 vga=0x318 
	initrd /initrd-2.6.27.19-170.2.35.fc10.i686.img
Comment 31 Rodd Clarkson 2009-03-07 23:28:31 EST
I've added vga=0x318, and while I now see fancy startup, it's not noticably changed anything in X.  I still can't use compiz for example.
Comment 32 Rodd Clarkson 2009-04-20 01:48:58 EDT
Okay, I'm all up-to-date with rawhide and I still don't have compiz working, good (acceptable) 3d performance, a graphical boot or any of the other things I would have thought should just work with this graphics card.

I'm using the 2.7.0 intel driver.

Should I just give up and expect that this card won't work?

It would be lovely if I had heard from one of the redhat developers about this bug, even if just to know that they are aware of it, that work is being done (somewhere) and that I'm not wasting my time supplying information.
Comment 33 Jonathan Dieter 2009-04-30 04:09:01 EDT
Perhaps bug #493307 is related to your problem.
Comment 34 Rodd Clarkson 2009-05-03 00:19:22 EDT
What a shame one of the xorg developers couldn't have just popped up and said that there's known issues with the g41 chipset and maybe pointed me to somewhere where I could have helped with testing.

*** This bug has been marked as a duplicate of bug 493307 ***
Comment 35 Matěj Cepl 2009-05-04 09:07:57 EDT
(In reply to comment #34)
> What a shame one of the xorg developers couldn't have just popped up and said
> that there's known issues with the g41 chipset and maybe pointed me to
> somewhere where I could have helped with testing.

The problem is that there are just so many xorg developers and that many bugs. I am sorry, but we are dancing as fast as we can.

Note You need to log in before you can comment on or make changes to this bug.