Bug 493547

Summary: Should obsolete libdhcp
Product: [Fedora] Fedora Reporter: Mamoru TASAKA <mtasaka>
Component: dhcpAssignee: David Cantrell <dcantrell>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dcantrell, pbrobinson, wwoods
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-03 21:51:52 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 446452    

Description Mamoru TASAKA 2009-04-02 04:09:37 EDT
Description of problem:
On my system, dhclient cannot be upgraded as:
# rpm -q dhclient libdhcp
[root@localhost System]# yum --disablerepo=koji-10 upgrade dhclient
Loaded plugins: dellsysidplugin2
Setting up Upgrade Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package dhclient.i586 12:4.1.0-13.fc11 set to be updated
--> Processing Dependency: libdhcp4client-4.0.so.0 for package: libdhcp
--> Finished Dependency Resolution
libdhcp-1.99.8-1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: libdhcp4client-4.0.so.0 is needed by package libdhcp-1.99.8-1.fc10.i386 (installed)
Error: Missing Dependency: libdhcp4client-4.0.so.0 is needed by package libdhcp-1.99.8-1.fc10.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. See above

Additional info:
For F-10 -> F-11 upgrade path, some package must obsolete
Comment 1 David Cantrell 2009-04-02 22:55:13 EDT
Fixed in dhcpv6-1.2.0-1.fc11 and dhcp-4.1.0-14.fc11.
Comment 2 Mamoru TASAKA 2009-04-03 11:28:40 EDT
@@ -72,6 +72,7 @@
 Requires(post): coreutils
 Obsoletes: dhcpcd <= 1.3.22pl1-7
 Obsoletes: libdhcp4client <= 12:4.0.0-31
+Obsoletes: libdhcp <= 1.99.8-1
 Provides: dhcpcd = 1.3.22pl1-8

Well, F-10 latest (and on my system) libdhcp is libdhcp-1.99.8-1.fc10
and 1.99.8-1 < 1.99.8-1.fc10
Comment 3 David Cantrell 2009-04-03 15:47:09 EDT
$ repoquery --whatobsoletes libdhcp

This is fixed in rawhide.
Comment 4 Mamoru TASAKA 2009-04-03 20:37:26 EDT
No, what I am saying that

# rpm -qp --obsoletes dhclient-4.1.0-14.fc11.i586.rpm 
dhcpcd <= 1.3.22pl1-7
libdhcp4client <= 12:4.0.0-31
libdhcp <= 1.99.8-1

This does not obsolete libdhcp-1.99.8-1.fc10, because
1.99.8-1.fc10 > 1.99.8-1.
Comment 5 David Cantrell 2009-04-03 21:51:52 EDT
Fixed in dhcp-4.1.0-15.fc11
Comment 6 Peter Robinson 2009-04-04 06:19:33 EDT
*** Bug 493209 has been marked as a duplicate of this bug. ***