Bug 494469

Summary: qemu-kvm fails to boot gPXE ROMs
Product: [Fedora] Fedora Reporter: Glauber Costa <gcosta>
Component: qemuAssignee: Glauber Costa <gcosta>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 11CC: dwmw2, ehabkost, gcosta, graeme.r.gillies, markmc, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-07 10:34:57 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 480594    
Attachments:
Description Flags
magic patch to fix this issue. none

Description Glauber Costa 2009-04-06 22:37:36 EDT
Description of problem:

Fedora QEMU Maintainer, AKA glommer, spent 3 whole days trying to make gpxe roms boot under kvm. They boot fine under qemu. They simply stall after gpxe menu.

After a lot of investigation, glommer discovered that the problem is the rom sits in a loop waiting for address 0x46c to change its value. This address is updated by the BIOS timer interrupt, which is not ticking.

Further investigation showed that receiving an interrupt seem to block further interrupts from happening correctly. It might be related to acking of interrupts of any kind. This seem to only happen in real mode.

It's not clear whether any interrupt will cause this behaviour.

Version-Release number of selected component (if applicable):
tip.

How reproducible:
Always

Steps to Reproduce:
1. Try to boot a gpxe option rom under kvm
2. cry.
3. There's no number 3.
  
Actual results:
glommer does not find the bug.

Expected results:
someone fixes it, and everyone gets happy.


Additional info:
Comment 1 Mark McLoughlin 2009-04-07 12:10:40 EDT
For reference, the original gPXE request was bug #457979
Comment 2 Glauber Costa 2009-04-07 19:52:43 EDT
New information on this: It seems to happen only on vmx boxes.

temporary solution is to buy from amd ;-)
Comment 3 Glauber Costa 2009-04-07 23:25:47 EDT
Created attachment 338650 [details]
magic patch to fix this issue.
Comment 4 Glauber Costa 2009-04-07 23:26:58 EDT
I just sent the attached patch upstream. It turns out to be a kernel problem.
We have to make sure this is included in F11 kernel, otherwise no one (but me! hehe) will be able to boot gpxe roms in intel machines.

Let us hope it goes smoothly and naturally during kernel rebases.
Comment 5 Mark McLoughlin 2009-04-09 10:34:01 EDT
Glauber has posted a couple more revisions of this patch, the latest is here:

  http://www.mail-archive.com/kvm@vger.kernel.org/msg12736.html
Comment 6 Fedora Admin XMLRPC Client 2009-05-07 08:12:31 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2009-05-07 08:13:34 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Admin XMLRPC Client 2009-05-07 08:14:02 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Admin XMLRPC Client 2009-05-07 13:58:23 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Bug Zapper 2009-06-09 09:23:02 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Mark McLoughlin 2009-08-07 10:34:57 EDT
Okay, bug #512358 tracks this issue better and has a backport of the fix to the F-11 kernel

*** This bug has been marked as a duplicate of bug 512358 ***