Bug 512358 - Unable to boot using qemu-kvm and gPXE from virt-preview repository
Unable to boot using qemu-kvm and gPXE from virt-preview repository
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 494469 (view as bug list)
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-07-17 10:04 EDT by Jan ONDREJ
Modified: 2009-09-29 11:18 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-29 11:18:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch 1 (6.23 KB, patch)
2009-07-17 10:28 EDT, Glauber Costa
no flags Details | Diff
patch 2 (4.12 KB, patch)
2009-07-17 10:28 EDT, Glauber Costa
no flags Details | Diff

  None (edit)
Description Jan ONDREJ 2009-07-17 10:04:01 EDT
Description of problem:
Unable to boot from PXE using new qemu packages from virt-preview repository (
http://markmc.fedorapeople.org/virt-preview/)

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.29.5-191.fc11.i686
qemu-0.10.50-11.kvm88.fc11.i586
qemu-kvm-0.10.50-11.kvm88.fc11.i586
gpxe-roms-qemu-0.9.7-4.fc11.noarch

How reproducible:
Always

Steps to Reproduce:
1. enable repository described here: http://markmc.fedorapeople.org/virt-preview
2. yum update
3. run: qemu-kvm -net nic,model=virtio -boot n -net tap,ifname=tap0

You need fully functional PXE booting on your network. If you don't have it, I can retest new kernel.
  
Actual results:
Press Ctrl-B to configure gPXE (PCI 00:00.0)...

then this virtual computer is running at 100% CPU, I can't type, ctrl-B does nothing, ... I can't only kill it.

Expected results:
Boot from PXE.

Additional info:
markmc suggested some urls:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=2809f5d2
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=310b5d306
Comment 1 Glauber Costa 2009-07-17 10:26:03 EDT
I have backports of those patches to a F11 kernel. It is the same patches that are included in the RHEL5 tree.

I'm attaching them to the BZ, so they can be picked up.
F12 won't need them.
Comment 2 Glauber Costa 2009-07-17 10:28:13 EDT
Created attachment 354155 [details]
patch 1

First patch. Allow us to manipulate interrupt shadow bit in emulated instructions
Comment 3 Glauber Costa 2009-07-17 10:28:58 EDT
Created attachment 354157 [details]
patch 2

use the previous infrastructure to set interrupt shadow after emulated instructions.
Comment 4 Alan Pevec 2009-08-06 14:43:03 EDT
workaround is to use etherboot ROMs, you need to fix /usr/share/qemu/pxe* symlinks
Comment 5 Hugh Brock 2009-08-06 16:44:21 EDT
This completely blocks booting VMs with KVM on f11 hosts. It would be very nice if we could get it fixed. The only workaround is to rip out gpxe, install etherboot, and fudge symlinks... which is ugly.
Comment 6 Mark McLoughlin 2009-08-07 10:34:57 EDT
*** Bug 494469 has been marked as a duplicate of this bug. ***
Comment 7 Justin M. Forbes 2009-08-10 12:01:45 EDT
Looks like this is fixed in 2.6.30 upstream which should be pushed to Fedora 11 at some point.  CVS for F-11 is already at 2.6.30, so there isn't really any way to easily push this patch before 2.6.30 is released.
Comment 8 Jan ONDREJ 2009-09-10 03:07:33 EDT
2.6.30.5 is out, but problem still persist.

[ondrejj@work ~]$ rpm -q kernel-PAE qemu-kvm
kernel-PAE-2.6.30.5-43.fc11.i686
qemu-kvm-0.10.92-1.fc11.i586
[ondrejj@work ~]$ uname -a
Linux work.salstar.sk 2.6.30.5-43.fc11.i686.PAE #1 SMP Thu Aug 27 21:34:36 EDT 2009 i686 i686 i386 GNU/Linux
Comment 9 Mark McLoughlin 2009-09-11 07:56:55 EDT
Thanks for testing Jan. It appears these patches only went into 2.6.30.6
Comment 10 Justin M. Forbes 2009-09-29 11:18:13 EDT
2.6.30.8-64.fc11 is now available for F-11 updates.  Please reopen this bug if there are further problems found.

Note You need to log in before you can comment on or make changes to this bug.