Bug 494605

Summary: Update Requires for numpy split
Product: [Fedora] Fedora Reporter: Jon Ciesla <limburgher>
Component: pygameAssignee: Christopher Stone <chris.stone>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: chris.stone, robin.norwood
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-15 15:19:12 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 494113    

Description Jon Ciesla 2009-04-07 11:35:27 EDT
Comment 1 Jon Ciesla 2009-04-07 14:14:40 EDT
Sorry, first time using python-bugzilla.  Here's that I meant to place there:

Your package currently Requires numpy.  Soon, numpy will split out -doc and
-f2py subpackages.  If your package does not use f2py, you need do nothing,
simply note that here and close this bug.  If your package does use f2py,
comment here, and I'll make sure you're notified when the split hits rawhide,
so you can change your Requires to numpy-f2py.  For further information, see
Comment 2 Jon Ciesla 2009-04-15 15:19:12 EDT
Does not appear to use f2py.
Comment 3 Jon Ciesla 2009-04-17 09:44:13 EDT
Whoops, this broke slingshot and solarwolf, see:

Comment 4 Jon Ciesla 2009-04-17 14:14:46 EDT
Turns out I didn't need to add the f2py dep after all.


I rebuilt numpy correctly, and corrected pygame in cvs, but I can't rebuild pygame until the corrected numpy is in the buildroots.
Comment 5 Jon Ciesla 2009-04-17 16:19:20 EDT
Did a chain build, and submitted a rel-eng ticket.