Bug 494113 - should numpy depend on python-devel?
should numpy depend on python-devel?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: numpy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On: 494598 494599 494600 494601 494602 494603 494604 494605 494606 494607 494608 494609 494610 494612 494613 494614 494615 494616 494617 494618 494619 494620
Blocks: FedoraOLPCDelta
  Show dependency treegraph
 
Reported: 2009-04-04 09:45 EDT by Peter Robinson
Modified: 2009-05-13 10:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 10:41:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2009-04-04 09:45:47 EDT
I don't believe the numpy rpm should have a "Requires: python-devel" but rather just have "BuildRequires: python-devel"
Comment 1 Jef Spaleta 2009-04-05 00:27:17 EDT
It's a valid requires with the current packaging see:

https://bugzilla.redhat.com/show_bug.cgi?id=488464
Comment 2 Peter Robinson 2009-04-05 05:34:17 EDT
With the current packaging it might be a valid requires, doesn't mean its correct. I've created a starting point for a package split here if you/the maintainer wishes to use it as a starting point.

http://pbrobinson.fedorapeople.org/numpy.spec
Comment 3 Jon Ciesla 2009-04-06 14:01:28 EDT
Looks reasonable, but we'll need to make sure that dependent packages, both for Requires and BuildRequires, are set appropriately.

repoquery on F-10 yields:

python-nltk-1:0.9.2-1.fc9.noarch
inkscape-0:0.46-6.fc10.i386
rpy-0:1.0.3-4.fc10.i386
python-numdisplay-0:1.4-2.fc10.noarch
veusz-0:1.2.1-1.fc10.i386
pyfits-0:1.3-3.fc9.noarch
gnuradio-0:3.1.2-2.fc10.i386
gnuradio-0:3.1.3-2.fc10.i386
plplot-0:5.9.0-2.svn8752.fc10.i386
PyQwt-0:5.1.0-4.fc10.i386
gnuplot-py-0:1.8-6.fc10.noarch
PySBIG-0:0.04-2.fc9.i386
pygame-0:1.8.1-2.fc10.i386
python-numdisplay-0:1.5.3-1.fc10.noarch
scipy-0:0.7.0-0.1.b1.fc10.i386
sugar-speak-0:9-3.fc10.noarch
expendable-0:0.0.8-1.fc10.noarch
anki-0:0.9.9.6-4.fc10.noarch
scitools-0:0.4-4.fc10.noarch
expendable-0:0.0.6-1.fc10.noarch
gdal-python-0:1.5.3-1.fc10.i386
inkscape-0:0.46-6.fc10.1.i386
PyQuante-0:1.6.3-1.fc10.i386
scipy-0:0.6.0-7.fc10.i386
python-fiat-0:0.3.4-2.fc10.noarch
pygsl-0:0.9.3-1.fc10.i386
python-matplotlib-0:0.98.1-1.fc10.i386
veusz-0:1.1-3.fc10.i386
rpy-0:1.0.3-6.fc10.i386


But I'm not sure how to quickly determine which need f2py and which need numpy.

Suggestions?  I mean, I can do it manually if need be, but. . .
Comment 4 Peter Robinson 2009-04-06 14:11:18 EDT
Probably the easiest way it to open a bug against each package and get its owner to either update the package if it needs f2py or close the bug as 'NOTABUG'. See 456122 as an example. Then give the package owners a couple week or so to update their packages and push the changes (see the mentioned bug - the changes have long been pushed but still have a number of bugs open).
Comment 5 Jon Ciesla 2009-04-06 16:01:21 EDT
What's the best way to file bulk bugs?
Comment 6 Peter Robinson 2009-04-06 16:20:25 EDT
I have no idea.
Comment 7 Jef Spaleta 2009-04-06 16:47:06 EDT
(In reply to comment #3)

I did a grep through the runtime scipy codebase and the matplotlib codebase and several scipy .so files reference f2py. I sort of expected that.  Let me know when you make the change so I can coordinate the BuildRequires and Requires change for scipy.

-jef
Comment 8 Jon Ciesla 2009-04-07 11:01:19 EDT
I'll just file them individually.  It's only 23 packages. 

Less-braindead list:

anki-0:0.9.9.6-4.fc10.noarch
expendable-0:0.0.8-1.fc10.noarch
gdal-python-0:1.5.3-1.fc10.i386
gnuplot-py-0:1.8-6.fc10.noarch
gnuradio-0:3.1.3-2.fc10.i386
inkscape-0:0.46-6.fc10.1.i386
plplot-0:5.9.0-2.svn8752.fc10.i386
pyfits-0:1.3-3.fc9.noarch
pygame-0:1.8.1-2.fc10.i386
pygsl-0:0.9.3-1.fc10.i386
PyQuante-0:1.6.3-1.fc10.i386
PyQwt-0:5.1.0-4.fc10.i386
PySBIG-0:0.04-2.fc9.i386
python-fiat-0:0.3.4-2.fc10.noarch
python-matplotlib-0:0.98.1-1.fc10.i386
python-nltk-1:0.9.2-1.fc9.noarch
python-numdisplay-0:1.5.3-1.fc10.noarch
rpy-0:1.0.3-6.fc10.i386
scipy-0:0.7.0-0.1.b1.fc10.i386
scitools-0:0.4-4.fc10.noarch
sugar-speak-0:9-3.fc10.noarch
veusz-0:1.1-3.fc10.i386
Comment 9 Jon Ciesla 2009-04-07 11:24:48 EDT
Just discovered python-bugzilla.  Looks like it doesn't do Blocks, but I can do that manually.
Comment 10 Jon Ciesla 2009-04-13 14:14:28 EDT
Thanks to all those that have responded.  Given that several haven't and the F11 Final Freeze is only a day away, I'll postpone until afterward, and do this in a new branch for F-12.

Package Change Request
======================
Package Name: numpy
New Branches: F-12
Owners: limb
Comment 11 Jef Spaleta 2009-04-13 14:33:08 EDT
is the form of the provides going to change?

Right now numpy in rawhide provides "f2py"  Is that what I should requires to future proof the change? Or is the name of the provides going to change?

-jef
Comment 12 Jon Ciesla 2009-04-13 14:39:24 EDT
Currently numpy Provides f2py.  In the new version, numpy-f2py will Provides f2py.  Only numpy-f2py will Requires python-devel.

You bring up an interesting point.  If all affected packages simply Requires f2py, I can just do the change and close all the bugs.
Comment 13 Jef Spaleta 2009-04-13 16:12:08 EDT
yep. I have scipy changes ready to commit i just wanted to make sure the form of the provides I need to grab wasn't going to change. 

For now I'm just going to BuildRequires and Requires f2py explicitly in scipy.  And then the OLPC people will come banging on my door next to figure out how to split up scipy into functional subpackages more effectively. 

-jef
Comment 14 Kevin Fenzi 2009-04-14 12:13:37 EDT
F-12? 

I assume you meant you would like a early F-11 branch so you could do work in devel that will not go out in F-11? cvs done for that. 
You should have a F-11 branch that will go out for F-11, and a devel that will be rawhide that will someday be F-12.
Comment 15 Jon Ciesla 2009-04-14 12:18:00 EDT
Thanks for both knowing what I really meant and doing it. :)
Comment 16 Jon Ciesla 2009-04-14 12:29:16 EDT
In CVS.  Builds of all sorts are dying in rawide right now, I'll try again tomorrow.

FYI, Peter, I made a slight deviation from your suggested spec.  I split out f2py, but didn't make -docs, since the documentation isn't very big.
Comment 17 Peter Robinson 2009-04-14 13:34:43 EDT
F-12? I'd still like to see this make F-11. the gnome-python stuff split around F-9 even though there are still dependant packages that aren't closed (see prev example). Also it was only recently that the python-devel dep was actually added as a dep to numpy which would indicate to me most people either don't use f2py, already have the stuff installed, didn't notice it was broken, or don't care :)

On the docs, the only reason I went for the -docs package was because some of the docs were for numpy and some for f2py so it sort of separated it all.
Comment 18 Jon Ciesla 2009-04-14 13:49:13 EDT
Well, the freeze was supposed to be today, but is being pushed back.  The build's not working anyway.  If I can get a build for F-12 to work, I'll try it for F-11 and see if it makes it in.  If not, it'll go in as an update.  If that's not good enough, we can petition for an exception:

https://fedoraproject.org/wiki/ReleaseEngineering/FinalFreezePolicy
Comment 19 Peter Robinson 2009-04-14 13:52:32 EDT
Cool. I had my package build in koji as a scratch from mem. I think the freeze is in time for the compose tomorrow morning. Saw a post of fedora-devel to something like that. I think it would be better to get it in if possible so there's some testing time before release, as opposed to straight after release.
Comment 20 Jon Ciesla 2009-04-14 13:58:24 EDT
My thought process exactly, for N-1 release.  We'll see what happens.
Comment 21 Jon Ciesla 2009-04-15 08:07:49 EDT
Built for F-12/devel and F-11-updates.  I'm on the fence about breaking the freeze.  Peter, do you have any reason that it would be better to have this in F-11 rather than as an immediate update?
Comment 22 Peter Robinson 2009-04-15 08:11:31 EDT
I would like it because it adds quite a bit to the size of the OLPC build which is due to be a F11 Spin. I don't particularly want to have to fork packages for small things like this.
Comment 23 Jon Ciesla 2009-04-15 09:26:58 EDT
Rel-Eng ticket filed:
https://fedorahosted.org/rel-eng/ticket/1461
Comment 24 Jon Ciesla 2009-04-15 15:00:31 EDT
This was just approved and tagged into F-11 final.  I'll start going through the list of open dependent bugs and trying to determine if any need fp2.
Comment 25 Jon Ciesla 2009-04-15 15:00:43 EDT
Or f2py.
Comment 26 Jon Ciesla 2009-04-15 16:08:18 EDT
Looks like it's just scipy.
Comment 27 Peter Robinson 2009-04-15 16:30:08 EDT
Excellent! Thanks all :-)
Comment 29 Peter Robinson 2009-05-13 06:20:53 EDT
I think this is fixed, can it be closed?
Comment 30 Jon Ciesla 2009-05-13 08:10:14 EDT
I don't see that scipy has been updated.  I'll comment on that bug.
Comment 31 Jon Ciesla 2009-05-13 10:41:12 EDT
All built in rawhide and necessary tag requests submitted.

Note You need to log in before you can comment on or make changes to this bug.