Bug 4953

Summary: slocate does not work properly
Product: [Retired] Red Hat Linux Reporter: blaine.kubesh
Component: slrnAssignee: David Lawrence <dkl>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-13 04:21:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description blaine.kubesh 1999-09-07 15:53:15 UTC
After a clean install of RH 6.0 on my box which has an 8Gig
drive I tried to do a locate on files that I know are on my
system. Locate fails to find most of my filenames on my
drive. I tried to re-install the slocate rpm as well as
deleting the /var/lib/slocate/* files and running updatedb
-u. This still did not work, arbitrary locates to files that
I know exist on the drive failed. Locate does return a
response but it is like the index is too small, it is just
not getting all of the results.

Comment 1 blaine.kubesh 1999-09-07 15:54:59 UTC
slocate does not appear on the component bug list!

Comment 2 blaine.kubesh 1999-09-07 18:31:59 UTC
- updatedb no longer does an slocate -u in RH6
  when typing updatedb you get usage, it should run slocate -u

- Here is an example of it not working. Try to do a locate on a known
  file like XBanner, i.e. 'locate XBanner'
  which is located in /usr/X11R1/lib/X11/app-defaults and notice
  that locate returns nil.
  (This example and others worked fine in RH5.2 and earlier)

Comment 3 Bill Nottingham 1999-09-07 19:28:59 UTC
Try the latest slocate from Raw Hide.

Comment 4 blaine.kubesh 1999-09-08 21:23:59 UTC
slocate-2_0-1 solved the problems I was having
Thx.