This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 495476

Summary: anaconda not formatting ext3 with same tune parameters as earlier versions
Product: [Fedora] Fedora Reporter: Tom Horsley <horsley1953>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 11CC: anaconda-maint-list, dcantrell, duck, jlaska, mike.cloaked, pjones, rmaximo, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: NEEDSRETESTING
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-25 15:20:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 495965    

Description Tom Horsley 2009-04-13 07:34:04 EDT
Description of problem:

I installed fedora 11 beta x86_64 a while back from the DVD. I reused an
old ext3 partition, telling it to reformat it as ext3. I am now seeing
the boot messages from fsck saying that the partition is scheduled for
a forced fsck check in 4 more boot attempts.

Previous versions of anaconda always adjusted the tune2fs parameters in
newly formatted ext3 partitions so none of these forced fsck checks would
occur.

Perhaps this is an unintended side effect of the great storage system
rewrite?

Version-Release number of selected component (if applicable):
whatever was on the fedora 11 beta DVD

How reproducible:
I only installed once, but I'm guessing it would do the same every time.

Steps to Reproduce:
1. install from DVD
2. reformat an ext3 partition during install
3.
  
Actual results:
Non-zero tune2fs -i or -c parameters (not sure which one).

Expected results:
Zero tune2fs -i and -c parameters as was the case in previous
anaconda versions.

Additional info:

Easy enough to run tune2fs myself once I saw the boot message (another good
reason to turn off rhgb and watch boot messages).

My other storage bug 494134 was more irritating than this one :-).
Comment 1 Chris Lumens 2009-05-08 11:37:13 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 2 James Laska 2009-05-18 15:11:49 EDT
Tom: Can you confirm whether the reported issue has been resolved with the latest anaconda package?

Information for installing rawhide is available at https://fedoraproject.org/wiki/Releases/Rawhide#Direct_Rawhide_install
Comment 3 Tom Horsley 2009-05-18 18:06:13 EDT
I'm unlikely to have time to try anything like this before it is too late
to make change (it didn't seem like a big deal anyway, running tune2fs can
fix it easily).
Comment 4 Mike C 2009-05-20 02:51:44 EDT
Is this only for x86_64 and not for i386?
Comment 5 Tom Horsley 2009-05-20 05:42:16 EDT
I only installed x86_64, so that's what I put in the original bug, but I'd
imagine that it happens (or is fixed) across all architectures the same
way.
Comment 6 Bug Zapper 2009-06-09 09:44:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping