Bug 494134 - anaconda blanks out disk label on reformat
anaconda blanks out disk label on reformat
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AnacondaStorage
  Show dependency treegraph
 
Reported: 2009-04-04 18:28 EDT by Tom Horsley
Modified: 2009-04-14 16:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 16:15:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2009-04-04 18:28:17 EDT
Description of problem:

Anaconda has always preserved the disk labels when formatting a partition,
but the new fedora 11 beta reset the label to blank when I formatted and
installed on an existing partition I wanted to reused for fedora 11.

This is a bit of a pain because my primary fedora 10 system would no
longer boot correctly since the fstab uses the LABEL= syntax and
the label was no longer there. (Easily corrected by rebooting back to
fedora 11 and using e2label, but still a pain).

Version-Release number of selected component (if applicable):
fedora 11 beta DVD

How reproducible:
I only installed once, but I imagine it would happen every time.

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
blank disk label

Expected results:
preserve existing disk label

Additional info:
Comment 1 David Lehman 2009-04-14 15:40:26 EDT
The label is part of the filesystem, which you have replaced. We are not creating labels any more because they are a poor solution to the problem of identifying devices by some means other than the device node name. We use UUIDs instead.
Comment 2 Tom Horsley 2009-04-14 15:47:38 EDT
It depends on what you do as to which ID is or is not a poor solution. UUIDs
can be just as poor: If you replace a disk and reinstall, the UUIDs will
all be different, you can manually recreate the same labels you used to
have, but recreating UUIDs isn't as easy. Every possible disk identifier
will turn out to be a pain in the patoot for someone under some
circumstance :-).
Comment 3 David Lehman 2009-04-14 16:06:37 EDT
That is exactly the reason we stopped using labels -- you can easily end up with the same label on several different devices, which is usually not desirable.

UUIDs, by definition, should be unique. You should avoid the practice of intentionally setting up duplicate UUIDs on multiple devices

We use UUIDs to come as close as possible to ensuring that we are referring to the specific device we mean to refer to. You want to be able to change the devices without changing their specifications, but most users do not. We are intentionally being explicit about the exact device we refer to. If you do not want this behavior you are welcome to use labels instead. We just won't do it for you.
Comment 4 Tom Horsley 2009-04-14 16:53:02 EDT
OK, if I'm free to use labels, then I should be free to specify the label
when I format the disk in anaconda, but it won't let me do that either.

All I'm looking for is predictable behaviour when I install on a multi-boot
system so I can have the new install's disk already setup to be mounted
in my old boot partitions. If you are gonna wipe out the label, then the
only possible predictable way to specify the disk is by using a device
name like /dev/sda5, which is really undesirable.

This doesn't seem like very exotic behaviour to me.

(And invoking the magic distro-jealousy principle, I'd point out that
the ubuntu and opensuse installers do let you specify labels and even
let you say which disk identifier you'd like in the fstab file :-).

Note You need to log in before you can comment on or make changes to this bug.