Bug 495748

Summary: yum localization half-working
Product: Red Hat Enterprise Linux 5 Reporter: Petr Šplíchal <psplicha>
Component: yumAssignee: Martin Bacovsky <mbacovsk>
Status: CLOSED NOTABUG QA Contact: BaseOS QE <qe-baseos-auto>
Severity: medium Docs Contact:
Priority: low    
Version: 5.3CC: james.antill, ohudlick
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 495750 (view as bug list) Environment:
Last Closed: 2009-04-14 12:12:49 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Petr Šplíchal 2009-04-14 11:53:28 EDT
Description of problem:

When running yum in different locale settings the messages are not
fully converted to current locale. For example "yum info python"
displays "summary" heading in english while the actual summary
text in current locale. The exactly opposite behavior can be
observed on current Fedora 10 (heading in local language but the
actual content in english).

Steps to Reproduce:
for lang in en_US de_DE pl_PL; do
    echo -e "\n\n$lang\n~~~~~~"
    LANG=$lang.UTF-8 yum info python | head -10
done

  
Actual results on RHEL5:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
yum-3.2.19-18.el5
python-2.4.3-24.el5

en_US
~~~~~~
Installed Packages
Name       : python
Arch       : x86_64
Version    : 2.4.3
Release    : 24.el5
Size       : 21 M
Repo       : installed
Summary    : An interpreted, interactive, object-oriented programming language.
URL        : http://www.python.org/


de_DE
~~~~~~
Installed Packages
Name       : python
Arch       : x86_64
Version    : 2.4.3
Release    : 24.el5
Size       : 21 M
Repo       : installed
Summary    : Eine interpretierte, interaktive,
           : objektorientierteProgrammiersprache.

pl_PL
~~~~~~
Installed Packages
Name       : python
Arch       : x86_64
Version    : 2.4.3
Release    : 24.el5
Size       : 21 M
Repo       : installed
Summary    : Interpretowany, interaktywny, obiektowy język programowania.
URL        : http://www.python.org/


Actual results on Fedora 10:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
yum-3.2.21-2.fc10.noarch
python-2.5.2-1.fc10.i386

en_US
~~~~~~
Loaded plugins: refresh-packagekit
Installed Packages
Name       : python
Arch       : i386
Version    : 2.5.2
Release    : 1.fc10
Size       : 16 M
Repo       : installed
Summary    : An interpreted, interactive, object-oriented programming language.
URL        : http://www.python.org/


de_DE
~~~~~~
Geladene Plugins: refresh-packagekit
Installierte Pakete
Name       : python
Architektur : i386
Version    : 2.5.2
Ausgabe    : 1.fc10
Grösse     : 16 M
Repo       : installed
Zusammenfassung    : An interpreted, interactive, object-oriented programming
                   : language.


pl_PL
~~~~~~
Wczytane wtyczki: refresh-packagekit
Zainstalowane pakiety
Nazwa              : python
Architektura       : i386
Wersja             : 2.5.2
Wydanie            : 1.fc10
Rozmiar            : 16 M
Repozytorium       : installed
Podsumowanie       : An interpreted, interactive, object-oriented programming
                   : language.


Expected results:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Both headings and the actual content should be displayed in the
current locale. The indentation should match the longest heading
(and should be the same for all items; too long for PL and varying
in the DE locale in the example above).

Checked /usr/share/locale/*/LC_MESSAGES/yum.mo for presence of
corresponding strings.
Comment 1 seth vidal 2009-04-14 11:56:47 EDT
The translations of pkg metadata are a function of the specspo pkg, not of yum. Yum just handles the the headings on the left and if rpm hands back translated metadata from specspo then yum uses that.
Comment 2 James Antill 2009-04-14 12:12:49 EDT
> For example "yum info python" displays "summary" heading in english

 Yum in RHEL has gettext translation of messages turned off, because that's what GA did ... noone requested the feature, and python likes to die in weird corner cases when you enable it.