Bug 497602

Summary: Virtualization group doesn't pull in qemu or kvm
Product: [Fedora] Fedora Reporter: Russell Strong <russell>
Component: qemuAssignee: Glauber Costa <gcosta>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: urgent    
Version: rawhideCC: berrange, crobinso, dwmw2, evan, gcosta, hbrock, luke, markmc, quintela, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-05-04 12:29:07 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 480593    

Description Russell Strong 2009-04-24 18:40:29 EDT
Description of problem:

Installed Virtuallisation with yum groupinstall Virtuallisation

after a reboot ( a day later ) I started virt-manager and get the following
message

Unable to open connection to hypervisor URI 'qemu:///system':
<class 'libvirt.libvirtError'> could not connect to qemu:///system
None

I checked the status of libvirtd.  It was running.
Comment 1 Cole Robinson 2009-04-27 09:29:30 EDT
This is likely due to the Virtualization group not pulling in qemu anymore:

https://www.redhat.com/archives/fedora-devel-list/2009-April/msg02195.html

If you 'yum install qemu' and reboot, does it fix the issue?
Comment 2 Russell Strong 2009-04-28 05:21:51 EDT
yes, that has fixed it.  Thanks.
Comment 3 Cole Robinson 2009-04-28 09:05:31 EDT
*** Bug 497963 has been marked as a duplicate of this bug. ***
Comment 4 Mark McLoughlin 2009-04-28 09:57:59 EDT
Fixed by qemu-0.10-15.fc11 which provides a qemu-kvm meta package which is pulled in by comps.

* Fri Apr 27 2009 Glauber Costa <glommer@redhat.com> - 2:0.10-15
- provide qemu-kvm as a metapackage

dist-f11 tag request here https://fedorahosted.org/rel-eng/ticket/1666
Comment 5 Mark McLoughlin 2009-05-01 08:20:01 EDT
Really fixed by qemu-0.10-16.fc11

* Fri May  1 2009 Mark McLoughlin <markmc@redhat.com> - 2:0.10-16
- Really provide qemu-kvm as a metapackage

We had forgotten to provide a %files section for the meta package, so it didn't actually get created.
Comment 6 Mark McLoughlin 2009-05-01 09:08:22 EDT
dist-f11 tag request https://fedorahosted.org/rel-eng/ticket/1705
Comment 7 Mark McLoughlin 2009-05-04 12:29:07 EDT
Tagged now
Comment 8 kim won ki 2009-06-11 08:28:49 EDT
I try to above comments : 'yum install qemu' and reboot.
but I met the same problem.
Unable to open connection to hypervisor URI 'qemu:///system':
<class 'libvirt.libvirtError'> could not connect to qemu:///system
None

I checked the status of libvirtd.  It was running.  

My System Information.

Plaform : x86_64
CPU : Intel Quad-Core Xeon E5506 Nehalem (2.13GHz) QPI 4.8 GT/sec L3 4MB, 80W x 2EA
Memory : DDR-III 4GB DDR3 ECC Registered x 6EA
HDD : Serial ATA-II 1TB 7200rpm (32MB) x 4EA

current rpm
qemu-system-cris-0.10.4-4.fc11.x86_64
qemu-system-ppc-0.10.4-4.fc11.x86_64
qemu-system-sparc-0.10.4-4.fc11.x86_64
qemu-user-0.10.4-4.fc11.x86_64
qemu-system-sh4-0.10.4-4.fc11.x86_64
qemu-0.10.4-4.fc11.x86_64
qemu-system-x86-0.10.4-4.fc11.x86_64
qemu-system-m68k-0.10.4-4.fc11.x86_64
qemu-common-0.10.4-4.fc11.x86_64
qemu-img-0.10.4-4.fc11.x86_64
qemu-system-mips-0.10.4-4.fc11.x86_64
qemu-kvm-0.10.4-4.fc11.x86_64
qemu-system-arm-0.10.4-4.fc11.x86_64

qemu-kvm-0.10.4-4.fc11.x86_64

How do I get qemu-0.10-16.fc11 rpm ?

If it isn't qemu package version problem, please slove the problem.~~
Comment 9 Daniel Berrange 2009-06-11 08:41:06 EDT
The original problem identified in this bug is resolved & thus this BZ is now closed. If you continue to have problems, please open a new bug to track its resolution.