This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 497963 - virt-manager should depend on qemu?
virt-manager should depend on qemu?
Status: CLOSED DUPLICATE of bug 497602
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 01:40 EDT by Evan Klitzke
Modified: 2009-04-28 09:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 09:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Evan Klitzke 2009-04-28 01:40:34 EDT
If you do `yum groupinstall Virtualization` you get virt-manager installed (and libvirtd), but not qemu. If you try to create a qemu/kvm connection in virt-manager you subsequently get a cryptic error message about not being able to connect to qemu:///system. This error is resolved by installing the `qemu` package.

In theory I suppose this is OK since virt-manager would still work with Xen, but AFAIK dom0 support isn't implemented in the 2.6.29 kernel, so in practice users must use KVM on Fedora 11. I think that virt-manager should depend on qemu for this reason, since Xen isn't really a viable alternative for F11 users.

At the very least, the Virtualization group should probably provide qemu, since that provides a looser dependency.

This is all wrt the fedora 11 beta. I have virt-manager version 0.7.0 release 4.fc11.
Comment 1 Cole Robinson 2009-04-28 09:05:31 EDT
This is an issue with the packages listed in the 'Virtualization' group.

*** This bug has been marked as a duplicate of bug 497602 ***

Note You need to log in before you can comment on or make changes to this bug.