Bug 498507

Summary: initial run of vncserver does not create xstartup config file
Product: [Fedora] Fedora Reporter: eric magaoay <ericm24x7>
Component: tigervncAssignee: Adam Tkac <atkac>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: atkac, ericm24x7, ovasik
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-05-04 12:54:22 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
xorg.0.log output none

Description eric magaoay 2009-04-30 15:34:31 EDT
Created attachment 341985 [details]
xorg.0.log output

Description of problem:
initial run of vncserver does not create "xstartup" config file due to the following error:
  xauth: (stdin):1:  bad display name "fdb5:1" in "add" command
NOTE: see below for complete outputs of vncserver

Version-Release number of selected component (if applicable):
Xvnc TigerVNC 0.0.90 - built Apr 27 2009 09:43:59
Installed Packages
tigervnc.x86_64                   0.0.90-0.6.20090427svn3789.fc11      installed
tigervnc-server.x86_64            0.0.90-0.6.20090427svn3789.fc11      installed
tigervnc-server-module.x86_64     0.0.90-0.6.20090427svn3789.fc11      installed

How reproducible:
persistent

Steps to Reproduce:
1. yum install tigervnc*
2. vncserver
  
Actual results:
outputs listed below

Expected results:
should be able to create the config file "xstartup"

Additional NOTES:
================
On previous build of tigervnc, while using Windows client VNC viewers (tried tightvnc and ultravnc), the screen remain blank. Linux version of VNC viewer works OK.
 
Additional info:
==============================
vncserver OUTPUTS: 
==============================
[adm5@fdb5 ~]$ vncserver

You will require a password to access your desktops.

Password:
Verify:
xauth: (stdin):1:  bad display name "fdb5:1" in "add" command

WARNING: The first attempt to start Xvnc failed, possibly because the X Font
Server is not running and this system does not use a font catalog.  Attempting
to determine an appropriate font path for this system and restart Xvnc using
that font path ...
Could not start Xvnc.


Xvnc TigerVNC 0.0.90 - built Apr 27 2009 09:43:59
Copyright (C) 2002-2005 RealVNC Ltd.
Copyright (C) 2000-2006 Constantin Kaplinsky
Copyright (C) 2004-2009 Peter Astrand for Cendio AB
See http://www.tigervnc.org for information on TigerVNC.
Underlying X server release 10601000, 


Thu Apr 30 15:13:04 2009
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      created VNC server for screen 0

Fatal server error:
could not open default font 'fixed'

Xvnc TigerVNC 0.0.90 - built Apr 27 2009 09:43:59
Copyright (C) 2002-2005 RealVNC Ltd.
Copyright (C) 2000-2006 Constantin Kaplinsky
Copyright (C) 2004-2009 Peter Astrand for Cendio AB
See http://www.tigervnc.org for information on TigerVNC.
Underlying X server release 10601000, 


Thu Apr 30 15:13:07 2009
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      created VNC server for screen 0

Fatal server error:
could not open default font 'fixed'

[adm5@fdb5 ~]$
Comment 1 Adam Tkac 2009-05-04 04:13:40 EDT
Could you check if installation of "xorg-x11-fonts-misc" package fixes your problem, please? (http://www.mail-archive.com/tigervnc-users@lists.sourceforge.net/msg00030.html)

Thanks.
Comment 2 eric magaoay 2009-05-04 12:38:21 EDT
installing xorg-x11-fonts-misc package does solved the problem. Thanks.
Not sure if that package needs to be added as a dependency or we must remember to install it.
Comment 3 Adam Tkac 2009-05-04 12:54:22 EDT
It was added as dependency in tigervnc-0.0.90-0.7.20090427svn3789.fc11, will be available soon.

*** This bug has been marked as a duplicate of bug 498184 ***