Bug 498708

Summary: Fedora 11 Preview installer does not configure mouse/cursor
Product: [Fedora] Fedora Reporter: David W. Legg <dwlegg>
Component: xorg-x11-drv-intelAssignee: Kristian Høgsberg <krh>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: rawhideCC: ajax, jbastian, mcepl, pjones, rmaximo, vanmeeuwen+fedora, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://h18000.www1.hp.com/products/quickspecs/11349_na/11349_na.HTML
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-05-07 21:21:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
lshal and Xorg.0.log
none
stdout from lshal
none
/var/log/Xorg.0.log none

Description David W. Legg 2009-05-02 10:10:07 UTC
Description of problem:
Booting from the preview installation DVD allows installation using keyboard but not mouse.  Have tried both PS22 and USB mouse.  The mouse/cursor only show
signs of working on the locale-choosing map bit of the installation,
nowhere else.  Even on the map, there is not a proper cursor, but you can work
out where it is from the disturbance of the map picture.

Version-Release number of selected component (if applicable):
anaconda on F11 preview 2009/04/28

How reproducible:
Every time on my HP Evo 510 51S P4 (i686) machine with both PS2 and USB mouse.
However, the problem did not occur on an AMD64 machine with USB mouse.
The URL above is the data sheet for the HP PC hardware.

Running 'Xorg -configure :1' gives this curious message:
'Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.'


Steps to Reproduce:
1. Boot from F11 preview DVD in HP Evo 510 S51.
2. Choose upgrade or install.
3.
  
Actual results:
No X cursor at all.

Expected results:
Cursor wiggles with mouse movement.

Additional info:
4. Complete install and reboot.
5. Still no mouse.
6. Ctrl-Alt-F2 -> log in as root.
7. lshal shows both USB and PS2 mouses detected, but no X cursor on Console #1.

[root@moses ~]# lshal | grep mouse
  access_control.type = 'mouse'  (string)
  info.capabilities = {'input', 'input.mouse', 'access_control'} (string list)
  info.product = 'Macintosh mouse button emulation'  (string)
  input.product = 'Macintosh mouse button emulation'  (string)
  info.product = 'IBM Enhanced (101/102-key, PS/2 mouse support)'  (string)
  pnp.description = 'IBM Enhanced (101/102-key, PS/2 mouse support)'  (string)
  info.linux.driver = 'psmouse'  (string)
  access_control.type = 'mouse'  (string)
  info.callouts.add = {'hal-acl-tool --add-device', 'hal-probe-vmmouse'} (string list)
  info.capabilities = {'input', 'input.mouse', 'access_control'} (string list)
[root@moses ~]#

Let me know if I can give more or better info. Ta.

Comment 1 David W. Legg 2009-05-02 13:37:36 UTC
Corrected URL: http://h18000.www1.hp.com/products/quickspecs/11349_na/11349_na.HTML

Same Intel 845G chipset, though.

Comment 2 Jeff Bastian 2009-05-04 15:21:48 UTC
Created attachment 342324 [details]
lshal and Xorg.0.log

I'm seeing similar behavior with an old Dell Dimension 3000 (Pentium 4) with:
   - Intel 82865G integrated graphics
   - Apple USB keyboard
   - Logitech USB optical mouse

Curiously, lshal shows "Macintosh mouse button emulation" even though it's a
Logitech mouse.  Maybe the Apple keyboard is confusing it?

The Xorg.0.log is also showing interesting messages:
(II) config/hal: Adding input device Macintosh mouse button emulation
...
(II) Logitech USB-PS/2 Optical Mouse: Found 8 mouse buttons
(II) Logitech USB-PS/2 Optical Mouse: Configuring as mouse

X is finding 2 mice?  But there's only one mouse on this system.

Attached are a copy of lshal output and Xorg.0.log from my system.

Comment 3 Matěj Cepl 2009-05-05 13:33:11 UTC
Created attachment 342459 [details]
stdout from lshal

Comment 4 Matěj Cepl 2009-05-05 13:34:00 UTC
Created attachment 342460 [details]
/var/log/Xorg.0.log

Comment 5 Adam Jackson 2009-05-07 21:21:29 UTC

*** This bug has been marked as a duplicate of bug 488980 ***