Bug 498708 - Fedora 11 Preview installer does not configure mouse/cursor
Fedora 11 Preview installer does not configure mouse/cursor
Status: CLOSED DUPLICATE of bug 488980
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
http://h18000.www1.hp.com/products/qu...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-02 06:10 EDT by David W. Legg
Modified: 2009-05-07 17:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 17:21:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal and Xorg.0.log (13.58 KB, application/x-gzip)
2009-05-04 11:21 EDT, Jeff Bastian
no flags Details
stdout from lshal (89.09 KB, text/plain)
2009-05-05 09:33 EDT, Matěj Cepl
no flags Details
/var/log/Xorg.0.log (34.33 KB, text/plain)
2009-05-05 09:34 EDT, Matěj Cepl
no flags Details

  None (edit)
Description David W. Legg 2009-05-02 06:10:07 EDT
Description of problem:
Booting from the preview installation DVD allows installation using keyboard but not mouse.  Have tried both PS22 and USB mouse.  The mouse/cursor only show
signs of working on the locale-choosing map bit of the installation,
nowhere else.  Even on the map, there is not a proper cursor, but you can work
out where it is from the disturbance of the map picture.

Version-Release number of selected component (if applicable):
anaconda on F11 preview 2009/04/28

How reproducible:
Every time on my HP Evo 510 51S P4 (i686) machine with both PS2 and USB mouse.
However, the problem did not occur on an AMD64 machine with USB mouse.
The URL above is the data sheet for the HP PC hardware.

Running 'Xorg -configure :1' gives this curious message:
'Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.'


Steps to Reproduce:
1. Boot from F11 preview DVD in HP Evo 510 S51.
2. Choose upgrade or install.
3.
  
Actual results:
No X cursor at all.

Expected results:
Cursor wiggles with mouse movement.

Additional info:
4. Complete install and reboot.
5. Still no mouse.
6. Ctrl-Alt-F2 -> log in as root.
7. lshal shows both USB and PS2 mouses detected, but no X cursor on Console #1.

[root@moses ~]# lshal | grep mouse
  access_control.type = 'mouse'  (string)
  info.capabilities = {'input', 'input.mouse', 'access_control'} (string list)
  info.product = 'Macintosh mouse button emulation'  (string)
  input.product = 'Macintosh mouse button emulation'  (string)
  info.product = 'IBM Enhanced (101/102-key, PS/2 mouse support)'  (string)
  pnp.description = 'IBM Enhanced (101/102-key, PS/2 mouse support)'  (string)
  info.linux.driver = 'psmouse'  (string)
  access_control.type = 'mouse'  (string)
  info.callouts.add = {'hal-acl-tool --add-device', 'hal-probe-vmmouse'} (string list)
  info.capabilities = {'input', 'input.mouse', 'access_control'} (string list)
[root@moses ~]#

Let me know if I can give more or better info. Ta.
Comment 1 David W. Legg 2009-05-02 09:37:36 EDT
Corrected URL: http://h18000.www1.hp.com/products/quickspecs/11349_na/11349_na.HTML

Same Intel 845G chipset, though.
Comment 2 Jeff Bastian 2009-05-04 11:21:48 EDT
Created attachment 342324 [details]
lshal and Xorg.0.log

I'm seeing similar behavior with an old Dell Dimension 3000 (Pentium 4) with:
   - Intel 82865G integrated graphics
   - Apple USB keyboard
   - Logitech USB optical mouse

Curiously, lshal shows "Macintosh mouse button emulation" even though it's a
Logitech mouse.  Maybe the Apple keyboard is confusing it?

The Xorg.0.log is also showing interesting messages:
(II) config/hal: Adding input device Macintosh mouse button emulation
...
(II) Logitech USB-PS/2 Optical Mouse: Found 8 mouse buttons
(II) Logitech USB-PS/2 Optical Mouse: Configuring as mouse

X is finding 2 mice?  But there's only one mouse on this system.

Attached are a copy of lshal output and Xorg.0.log from my system.
Comment 3 Matěj Cepl 2009-05-05 09:33:11 EDT
Created attachment 342459 [details]
stdout from lshal
Comment 4 Matěj Cepl 2009-05-05 09:34:00 EDT
Created attachment 342460 [details]
/var/log/Xorg.0.log
Comment 5 Adam Jackson 2009-05-07 17:21:29 EDT

*** This bug has been marked as a duplicate of bug 488980 ***

Note You need to log in before you can comment on or make changes to this bug.