Bug 499236

Summary: Create custom partition - Anaconda crashes
Product: [Fedora] Fedora Reporter: Raphos <r.henninger>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: ahe, anaconda-maint-list, anant.s.more, bugchaser, fedora, imsaad73, lnarayana_v, mdixon, merlinschindlbeck, mwkz, nierogama, phyoung77, pjones, r.henninger, rmaximo, tjb, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: anaconda_trace_hash:a2901b1c84d49da56239135af494d2bf4bfddf17bad6ef9c74650f198330c6db
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-05-05 15:55:19 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda. none

Description Raphos 2009-05-05 13:58:28 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 1718, in devices
    raise DeviceTreeError("duplicate paths in device tree")
  File "/usr/lib/anaconda/storage/__init__.py", line 310, in disks
    devices = self.devicetree.devices
  File "/usr/lib/anaconda/iw/partition_gui.py", line 784, in populate
    disks = self.storage.disks
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1041, in refresh
    self.populate()
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1113, in editPartition
    if self.refresh(justRedraw=not actions):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 962, in newCB
    self.editPartition(device, isNew=1)
DeviceTreeError: duplicate paths in device tree
Comment 1 Raphos 2009-05-05 13:58:54 EDT
Created attachment 342511 [details]
Attached traceback automatically from anaconda.
Comment 2 Raphos 2009-05-05 14:43:15 EDT
Description of problem:

I tried to create custom partition layout while installing Fedora 11 preview from a usb hard drive.

Anaconda crashes.


How reproducible:
100%

Steps to Reproduce:
1. Installing Fedora 11 preview
2. when the partitioner screen is reached, select 'Create custom layout'
3. create partition /boot 
4. create partition /swap

=> anaconda crashes
Comment 3 Raphos 2009-05-05 14:59:51 EDT
PS: I tried to create custom partition on an extended partition (sdb2), sdb1 is a NTFS partition...
Comment 4 Chris Lumens 2009-05-05 15:55:19 EDT

*** This bug has been marked as a duplicate of bug 493058 ***
Comment 5 Raphos 2009-05-05 16:55:07 EDT
(In reply to comment #4)
> 
> *** This bug has been marked as a duplicate of 493058 ***  


  Ok, thanks for your answer. And now ? How can I install Fedora 11 preview ? Will it be the same problem with the final version of Fedora 11 ??
Comment 6 Raphos 2009-05-17 15:08:20 EDT
Created attachment 344350 [details]
Attached traceback automatically from anaconda.
Comment 7 Piotr Drąg 2009-06-09 15:39:13 EDT
Created attachment 347079 [details]
Attached traceback automatically from anaconda.
Comment 8 Thomas J. Baker 2009-06-16 09:38:02 EDT
Created attachment 348108 [details]
Attached traceback automatically from anaconda.
Comment 9 Edwin ten Brink 2009-06-17 16:47:54 EDT
Created attachment 348345 [details]
Attached traceback automatically from anaconda.
Comment 10 lakshminarayana 2009-07-09 01:31:35 EDT
Created attachment 351014 [details]
Attached traceback automatically from anaconda.
Comment 11 lakshminarayana 2009-07-09 01:40:29 EDT
Created attachment 351015 [details]
Attached traceback automatically from anaconda.
Comment 12 Mark Dixon 2009-07-12 23:49:53 EDT
Created attachment 351423 [details]
Attached traceback automatically from anaconda.
Comment 13 anant more 2009-07-14 11:21:58 EDT
Created attachment 351601 [details]
Attached traceback automatically from anaconda.
Comment 14 anant more 2009-07-14 11:45:01 EDT
Created attachment 351614 [details]
Attached traceback automatically from anaconda.
Comment 15 bugchaser 2009-07-19 21:40:40 EDT
Created attachment 354295 [details]
Attached traceback automatically from anaconda.
Comment 16 bugchaser 2009-07-28 18:48:24 EDT
Created attachment 355471 [details]
Attached traceback automatically from anaconda.
Comment 17 Joel Andres Granados 2009-08-05 11:06:37 EDT
*** Bug 515460 has been marked as a duplicate of this bug. ***
Comment 18 Walid Zein 2009-08-22 19:19:10 EDT
Created attachment 358333 [details]
Attached traceback automatically from anaconda.
Comment 19 Walid Zein 2009-08-22 19:45:06 EDT
How to solve this problem? or it is better to forget Fedora 11 and return to version 10?

Thanks
Comment 20 Andy Lindeberg 2009-08-24 10:15:06 EDT
This should be fixed in rawhide. Please give the latest spin a try and post on 493058 if you're still running into it.
Comment 21 nierogama 2009-09-15 07:54:09 EDT
Created attachment 361070 [details]
Attached traceback automatically from anaconda.
Comment 22 hyeyoung park 2009-09-29 21:43:27 EDT
Created attachment 363099 [details]
Attached traceback automatically from anaconda.
Comment 23 hyeyoung park 2009-09-29 21:51:17 EDT
Created attachment 363102 [details]
Attached traceback automatically from anaconda.
Comment 24 Ibrahim Darwish 2009-10-09 08:15:28 EDT
Created attachment 364241 [details]
Attached traceback automatically from anaconda.
Comment 25 Ibrahim Darwish 2009-10-09 08:19:56 EDT
Created attachment 364242 [details]
Attached traceback automatically from anaconda.
Comment 26 Merlin Schindlbeck 2009-10-19 16:16:40 EDT
Created attachment 365274 [details]
Attached traceback automatically from anaconda.
Comment 27 Raphos 2009-10-19 16:59:35 EDT
Create at first your own partitions with Gparted live CD and make F11 install.