Bug 499662

Summary: anaconda -50 traceback: attribute error
Product: [Fedora] Fedora Reporter: Clyde E. Kunkel <clydekunkel7734>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 11CC: anaconda-maint-list, jlaska, rmaximo, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: anaconda_trace_hash:3aeec64fb15ab0f3e1c5e06ecaf95e68f019e6300ec3ce009ea6894943665807
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-09 09:25:56 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 495965    
Attachments:
Description Flags
Attached traceback automatically from anaconda.
none
FSError: filesystem has not been created none

Description Clyde E. Kunkel 2009-05-07 11:16:17 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.50 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 183, in __init__
    self.partedPartition = partition.partedPartition
  File "/usr/lib/anaconda/iw/partition_gui.py", line 258, in add
    stripe = DiskStripeSlice(self, partition, self.tree, self.editCB)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 819, in populate
    stripe.add(device)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1338, in getScreen
    self.populate(initial = 1)
  File "/usr/lib/anaconda/gui.py", line 1423, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1340, in nextClicked
    self.setScreen ()
AttributeError: 'NoneType' object has no attribute 'partedPartition'
Comment 1 Clyde E. Kunkel 2009-05-07 11:16:24 EDT
Created attachment 342856 [details]
Attached traceback automatically from anaconda.
Comment 2 Clyde E. Kunkel 2009-05-07 11:25:26 EDT
http://etc install from redhat.com.
After detecting storage devices, including encrypted LVs, got traceback after clicking custom partitioning.
Comment 3 Chris Lumens 2009-05-07 15:15:47 EDT
*** Bug 499714 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2009-05-07 19:02:24 EDT
This should be fixed in the next build of anaconda.
Comment 5 Clyde E. Kunkel 2009-05-08 14:47:06 EDT
Couldn't test due to bz 499854.
Comment 6 James Laska 2009-05-08 15:10:15 EDT
Per discussion on irc://irc.freenode.net/#anaconda ... adding to F11AnacondaBlocker
Comment 7 James Laska 2009-05-11 16:47:53 EDT
I will attempt to retest using the following reproducer noted in bug#499714

= Steps to reproduce =

* Install autopart
* Initiate a new install, and select 'Custom partition'
* resize previous '/' logical volume to 5000
* add a new '/' using remaining free space in volume group
* resize previous '/boot' partition from 196 to 195
Comment 8 Clyde E. Kunkel 2009-05-14 14:26:47 EDT
with anaconda .52, got into the custom partitioning which is good, but then hit 499828 which may not be related.  Will try again without trying to mount any luks LVs.
Comment 9 Clyde E. Kunkel 2009-05-14 18:35:15 EDT
Not using the comment 7 method and not mounting any luks LVs, installed OK.
Comment 10 James Laska 2009-05-15 08:11:15 EDT
Retesting this bug using the procedure in comment#7, I ran into bug#500991
Comment 11 James Laska 2009-05-15 08:23:17 EDT
While re-editing the previous '/' logical volume during the produced in comment#7, I also ran into bug#500995
Comment 12 James Laska 2009-05-15 08:58:27 EDT
Retesting the exact procedure in comment#7 this time does *not* result in the reported failure.  

I do however hit bug#501000 while attempting to activate the partitions.
Comment 13 Clyde E. Kunkel 2009-05-15 12:02:25 EDT
Created attachment 344192 [details]
FSError: filesystem has not been created

Following the above test case, when I tried to activate I got the attached traceback--seems to be a new bug?  If so I can create a new bz, auto bz after the traceback would not work since it insists on looking for storage devices when those routines may have been clobbered--bz 497240.

I did not do the install autopart step since I don't know how to do that and assumed (correctly, I hope) that it is part of anaconda.
Comment 14 Clyde E. Kunkel 2009-05-15 12:06:25 EDT
Forgot to add I inspected both / and /boot after the failure and they were not touched during the attempt.
Comment 15 James Laska 2009-05-15 12:20:21 EDT
Clyde: looks like you and I both hit bug#500991
Comment 16 James Laska 2009-05-29 10:38:37 EDT
Unable to retest, blocked by bug#501000.  The reproducer is posted in this and the other bug (https://bugzilla.redhat.com/show_bug.cgi?id=501000#c6).
Comment 17 James Laska 2009-06-09 09:25:56 EDT
Retested using anaconda-11.5.0.59 (F-11-RC4) and no longer seeing this failure.  Closing this bug.
Comment 18 Bug Zapper 2009-06-09 11:21:41 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping