Bug 499714 - AttributeError: 'NoneType' object has no attribute 'partedPartition'
AttributeError: 'NoneType' object has no attribute 'partedPartition'
Status: CLOSED DUPLICATE of bug 499662
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:9e5d2e6cbb96690f4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-07 14:57 EDT by James Laska
Modified: 2013-09-02 02:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 15:15:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (235.98 KB, text/plain)
2009-05-07 14:58 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-05-07 14:57:56 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.50 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 183, in __init__
    self.partedPartition = partition.partedPartition
  File "/usr/lib/anaconda/iw/partition_gui.py", line 258, in add
    stripe = DiskStripeSlice(self, partition, self.tree, self.editCB)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 819, in populate
    stripe.add(device)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1040, in refresh
    self.populate()
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1112, in editPartition
    if self.refresh(justRedraw=not actions):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1067, in editCB
    self.editPartition(device)
AttributeError: 'NoneType' object has no attribute 'partedPartition'
Comment 1 James Laska 2009-05-07 14:58:01 EDT
Created attachment 342917 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-05-07 15:00:49 EDT
= Steps to reproduce =

* Install autopart
* Initiate a new install, and select 'Custom partition'
* resize previous '/' logical volume to 5000
* add a new '/' using remaining free space in volume group
* resize previous '/boot' partition from 196 to 195
Comment 3 Chris Lumens 2009-05-07 15:15:47 EDT

*** This bug has been marked as a duplicate of bug 499662 ***

Note You need to log in before you can comment on or make changes to this bug.