This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 499970

Summary: RFE: port libvirt to PolicyKit 1.0
Product: [Fedora] Fedora Reporter: Matthias Clasen <mclasen>
Component: libvirtAssignee: Daniel Berrange <berrange>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: ajia, awilliam, berrange, clalance, crobinso, itamar, lists.kho, markmc, twaugh, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-14 13:33:27 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 498969, 515619    
Attachments:
Description Flags
Fix for policy API/ABI breakage none

Description Matthias Clasen 2009-05-09 12:57:07 EDT
We are going to land polkit 1.0 in F12 soon. This is going to require changes
to polkit using applications. Thankfully, mostly simplifications.

See http://fedoraproject.org/wiki/Features/PolicyKitOne
Comment 1 Mark McLoughlin 2009-05-18 03:11:20 EDT
Some discussion related to this on fedora-devel-list:

  http://www.redhat.com/archives/fedora-devel-list/2009-May/thread.html#01332
Comment 2 Bug Zapper 2009-06-09 11:33:08 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Matthias Clasen 2009-07-08 20:02:34 EDT
Has anybody looked at this ?
Comment 4 Adam Williamson 2009-07-17 14:27:56 EDT
We discussed this at the release blocker bug meeting this morning. Eventually we decided to go with Jesse Keating's position: until all PolicyKit 1.0 ports are done, the old PolicyKit packages will be kept in F12. Thus we would not delay the release if all ports were not complete for release time, but just complete them as post-release updates. Thus 'port to PolicyKit 1.0' bugs are not release critical. Hence downgrading to F12Target.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Daniel Berrange 2009-07-17 14:42:39 EDT
FYI  I don't expect to have this bug fixed prior to the feature freeze, since we have faaar to many other libvirt new features to deal with as higher priority. We'll still aim to get this patched before the beta release though.
Comment 6 Matthias Clasen 2009-08-03 16:23:49 EDT
I sure hope you do, since we are still aiming to obsolete PolicyKit 0.9 before the beta release...
Comment 7 Daniel Berrange 2009-08-04 09:44:12 EDT
Created attachment 356175 [details]
Fix for policy API/ABI breakage
Comment 8 Mark McLoughlin 2009-08-10 09:44:39 EDT
URL of upstream discussion:

  http://www.redhat.com/archives/libvir-list/2009-August/msg00108.html
Comment 9 Daniel Berrange 2009-08-13 11:38:44 EDT
*** Bug 515619 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Berrange 2009-08-13 11:59:58 EDT
*** Bug 517112 has been marked as a duplicate of this bug. ***
Comment 11 Daniel Berrange 2009-08-13 12:00:35 EDT
Built in libvirt-0.7.0-4.fc12
Comment 12 Adam Williamson 2009-08-13 12:55:05 EDT
I can confirm that seems to work, at least as far as my bug https://bugzilla.redhat.com/show_bug.cgi?id=515619 is concerned (with the new libvirt, I don't have that problem when running virt-manager any more, it correctly starts up and asks for root privileges).

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Martin Kho 2009-08-28 13:44:03 EDT
Hi,

I'm running libvirt-0.7.0.6.fc12 and don't get an authentication box. Regression?

Martin Kho
Comment 14 Martin Kho 2009-08-28 14:31:04 EDT
Re-installed libvirt-0.7.0.6.fc12 and everything seems fine now. Don't know what was wrong. Sorry for the 'spam' :-)

Martin Kho