This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 517112 - virt-manager fails to connect
virt-manager fails to connect
Status: CLOSED DUPLICATE of bug 499970
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On: 517257
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-12 12:18 EDT by Tim Waugh
Modified: 2009-08-13 11:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-13 11:59:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2009-08-12 12:18:41 EDT
Description of problem:
virt-manager fails to connect to libvirt.  I'm logged in at the console on a fresh rawhide install, and libvirtd is running.

Version-Release number of selected component (if applicable):
libvirt-0.7.0-3.fc12.x86_64
virt-manager-0.8.0-1.fc12.noarch

How reproducible:
100%

Steps to Reproduce:
1.Start virt-manager.
  
Actual results:
'Connection Failure' dailog:

Unable to open a connection to the libvirt management daemon.

Libvirt URI is: qemu:///system

Verify that:
 - The 'libvirtd' daemon has been started

Unable to open connection to hypervisor URI 'qemu:///system':
Failed to collect auth credentials
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 456, in _try_open
    None], flags)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 102, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: Failed to collect auth credentials

Worked fine in Fedora 11.
Comment 1 Tim Waugh 2009-08-13 05:31:18 EDT
strace reveals this to have the same cause as bug #515906:

[pid  4303] read(19, "l\3\1\1^\0\0\0\7\0\0\0u\0\0\0\6\1s\0\6\0\0\0:1.193\0\0\4\1
s\0)\0\0\0org.freedesktop.DBus.Error.NameHasNoOwner\0\0\0\0\0\0\0\5\1u\0\5\0\0\0
\10\1g\0\1s\0\0\7\1s\0\24\0\0\0org.freedesktop.DBus\0\0\0\0Y\0\0\0Could not get 
owner of name 'org.freedesktop.PolicyKit.AuthenticationAgent': no such name\0"..
., 2048) = 230
Comment 2 Daniel Berrange 2009-08-13 11:59:58 EDT

*** This bug has been marked as a duplicate of bug 499970 ***

Note You need to log in before you can comment on or make changes to this bug.