Bug 501375

Summary: anaconda tries to resize lvm volumes it should touch
Product: [Fedora] Fedora Reporter: Tomas Mraz <tmraz>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: anaconda-maint-list, rmaximo, roland, vanmeeuwen+fedora, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: NEEDSRETESTING
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-05-21 10:57:01 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 495965    

Description Tomas Mraz 2009-05-18 16:20:53 EDT
I've tried rawhide install from todays image. Although in the custom disk layout I've told anaconda to reformat only one volume from a LVM volgroup on my disk drive it tried to resize all the logical volumes in the volgroup. Of course resize2fs then reported "Nothing to do." as the size of these volumes was not changed. The unfortunate consequence was that full fsck was run on each of these volumes twice. Although nothing was broken the fsck took a long time to complete.
Comment 1 Jeremy Katz 2009-05-18 20:23:09 EDT
I saw this too.  We think this will be fixed in .53, but it definitely needs verifying and if not this should be fixed for release as there is a chance it could break things
Comment 2 Jeremy Katz 2009-05-19 15:45:44 EDT
*** Bug 501575 has been marked as a duplicate of this bug. ***
Comment 3 Will Woods 2009-05-20 16:49:06 EDT
Should be fixed in today's Rawhide - can any of the reporters confirm that?
Comment 4 Roland McGrath 2009-05-20 23:39:05 EDT
Looks good here.