Bug 501575 - anaconda better keep its grubby fingers off my other partitions!
anaconda better keep its grubby fingers off my other partitions!
Status: CLOSED DUPLICATE of bug 501375
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-19 15:41 EDT by Roland McGrath
Modified: 2009-05-19 15:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 15:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roland McGrath 2009-05-19 15:41:32 EDT
Description of problem:

F11 anaconda has acquired a new and insane misfeature that I cannot abide.
I use "Custom layout" to select one of many existing partitions to use for /boot and a new LV of an existing VG to use for / for the new install.  I have been using anaconda this way since before Fedora was Fedora.

As of F11, all of a sudden it thinks that I want it to think a solitary thing about all my other partitions and LVs that I did not touch or request to mount in this install, which I don't.  It now runs e2fsck on all these LVs, which I did not authorize, do not want, and cannot believe anyone thought was acceptable behavior.  This must cease at once.

The installer has no business whatsoever even looking at any partition or LV I have not configured in the partitioning menus, let alone a modifying operation like e2fsck -f -p.  This new misfeature is completely unacceptable.  I will have to advise everyone who asks not to use the F11 installer on any machine they care about until this shocking misfeature is removed.

Version-Release number of selected component (if applicable):
anaconda-11.5.0.52-1.fc11.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2009-05-19 15:45:44 EDT

*** This bug has been marked as a duplicate of bug 501375 ***

Note You need to log in before you can comment on or make changes to this bug.