Bug 503575

Summary: LiveCD Installer hangs during guest VM install-to-virt-drive
Product: [Fedora] Fedora Reporter: Don Davis <dodavis>
Component: qemuAssignee: Glauber Costa <gcosta>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: 11CC: berrange, clalance, dwmw2, ehabkost, gcosta, itamar, markmc, quintela, sgallagh, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: 0.10.5-2.fc11 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-15 22:28:50 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 480594    

Description Don Davis 2009-06-01 14:52:31 EDT
Description of problem:  As soon as i try to install F10 or F11 from LiveCD
to my VM's virtual HD (also running F10 or F11), the installation hangs:
the installer's blue spash screen appears, and the guest's CPU load drops 
below 1%.

Version-Release number of selected component (if applicable):
qemu-kvm x86_64, v. 0.10.4

How reproducible:  consistent for me, one coworker has replicated on his T61/F11


Steps to Reproduce:
1. in virt-manager, boot VM from a .iso file
2. double-click on the "Install to hard drive" icon
3.
  
Actual results:  installer and reboot fails to progreess, the guests's CU load collapses, and the parent's disk activity goes quiet, too.


Expected results:


Additional info:  this failure shows up on:
   * my t500, running F11;
   * my old t61, running F10.  
   * sgallagh's t61, running F11
Comment 1 Stephen Gallagher 2009-06-01 14:55:15 EDT
I experienced this failure when installing the Fedora 10 x86_64 LiveCD (Gnome) in F11 (fully updated as of 6/1/2009).

However, an install of the Fedora 11 Preview x86_64 LiveCD completed successfully for me.

I was unable to identify any log messages that looked suspicious.
Comment 2 Don Davis 2009-06-01 16:45:20 EDT
i replaced my F10 .iso with F11-Preview.  Now the install-to-hard-drive
completes, but after reboot, the restart stalls with a 100% white-on-black 
progress bar.   - don davis
Comment 3 Don Davis 2009-06-01 17:52:34 EDT
this bug is severely blocking me.  i have to run some kerberos tests, and i need VMs in order to do so.  i've spent 4 fruitless days trying to get virt / kvm to
work.
Comment 4 Don Davis 2009-06-01 19:28:48 EDT
gcosta (glommer) told me tonight that his version 0.10.5-1 
fixes my problem, and he's right, my installed VM is working 
now.  on koji: qemu-*-0.10.5-1.fc11.x86_64.rpm

thanks, glommer!        - don davis, IPA group, westford
Comment 5 Mark McLoughlin 2009-06-03 09:27:53 EDT
Thanks for testing, Don
Comment 6 Mark McLoughlin 2009-06-03 11:27:29 EDT
Okay, Stephen says it doesn't fix the issue for him

Please try again with the qemu-0.10.5-2.fc11 update - it fixes a cdrom issue that could be the underlying cause here
Comment 7 Fedora Update System 2009-06-03 12:21:19 EDT
qemu-0.10.5-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.5-2.fc11
Comment 8 Mark McLoughlin 2009-06-03 17:35:58 EDT
Stephen/Don - thanks for testing and adding a comment to the update
Comment 9 Bug Zapper 2009-06-09 12:56:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Fedora Update System 2009-06-15 22:28:16 EDT
qemu-0.10.5-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.