Bug 504951

Summary: ping does nslookup, nslookup works, wget fails with error in temporary name resolution.
Product: [Fedora] Fedora Reporter: Tom Stocker <neo>
Component: nss-mdnsAssignee: Lennart Poettering <lpoetter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 11CC: anton, arxs, coffee177, dali.spam, danw, dcbw, dyland.desmarais, jacquesdong, karlikt, lpoetter, martin, maurizio.antillon, neo, peter.l, p.schultz, redhat, sean
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-07-22 19:08:15 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Tom Stocker 2009-06-10 03:44:28 EDT
Description of problem:

ping works, nslookup works, in wget, FF and all other applications i get no nameserver lookup. Hardware is ok, as it works all fine on an dualboot XP.
It can't be the driver because the problem exists in lan and wlan. Also had this problem within rawhide (11). It's all out-of-the box, it's an standard installation on an Lifebook E8210.

Version-Release number of selected component (if applicable):

Fedora 11 final

How reproducible:

on my home lan always, in the office sometimes. 

Steps to Reproduce:
1. boot
2. connect lan or wlan
3. tests below
  
Actual results:

temorary failure in name resolution

Expected results:

working name lookups

Additional info:

[tom@andromeda ~]$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:17:42:23:51:2A 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:16

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1040 (1.0 KiB)  TX bytes:1040 (1.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:C0:A8:D6:F0:65 
          inet addr:192.168.2.36  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::2c0:a8ff:fed6:f065/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:58 errors:0 dropped:0 overruns:0 frame:0
          TX packets:85 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:7075 (6.9 KiB)  TX bytes:11653 (11.3 KiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-C0-A8-D6-F0-65-A0-E8-00-00-00-00-00-00-00-00 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

[tom@andromeda ~]$ ping www.google.ch
PING www.l.google.com (74.125.43.147) 56(84) bytes of data.
64 bytes from bw-in-f147.google.com (74.125.43.147): icmp_seq=1 ttl=50 time=44.2 ms
64 bytes from bw-in-f147.google.com (74.125.43.147): icmp_seq=2 ttl=50 time=43.8 ms
^C
--- www.l.google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1885ms
rtt min/avg/max/mdev = 43.808/44.019/44.230/0.211 ms
[tom@andromeda ~]$ su -
Password:
[root@andromeda ~]# yum update
Loaded plugins: refresh-packagekit
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again
[root@andromeda ~]# wget www.google.ch
--2009-06-10 00:51:22--  http://www.google.ch/
Resolving www.google.ch... failed: Temporary failure in name resolution.
wget: unable to resolve host address `www.google.ch'
[root@andromeda ~]# cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 192.168.2.1
[root@andromeda ~]# ping 192.168.2.1
PING 192.168.2.1 (192.168.2.1) 56(84) bytes of data.
64 bytes from 192.168.2.1: icmp_seq=1 ttl=255 time=2.11 ms
^C
--- 192.168.2.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 748ms
rtt min/avg/max/mdev = 2.113/2.113/2.113/0.000 ms
[root@andromeda ~]# nslookup www.google.ch
Server:      192.168.2.1
Address:   192.168.2.1#53

Non-authoritative answer:
www.google.ch   canonical name = www.google.com.
www.google.com   canonical name = www.l.google.com.
Name:   www.l.google.com
Address: 74.125.43.99
Name:   www.l.google.com
Address: 74.125.43.103
Name:   www.l.google.com
Address: 74.125.43.104
Name:   www.l.google.com
Address: 74.125.43.106
Name:   www.l.google.com
Address: 74.125.43.147
Name:   www.l.google.com
Address: 74.125.43.105

[root@andromeda ~]# ping 74.125.43.99
PING 74.125.43.99 (74.125.43.99) 56(84) bytes of data.
64 bytes from 74.125.43.99: icmp_seq=1 ttl=50 time=44.6 ms
64 bytes from 74.125.43.99: icmp_seq=2 ttl=50 time=47.4 ms
^C
--- 74.125.43.99 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1094ms
rtt min/avg/max/mdev = 44.617/46.016/47.415/1.399 ms
[root@andromeda ~]# wget http://www.google.ch
--2009-06-10 00:52:07--  http://www.google.ch/
Resolving www.google.ch... failed: Temporary failure in name resolution.
wget: unable to resolve host address `www.google.ch'
[root@andromeda ~]# env | grep pro
[root@andromeda ~]#
[root@andromeda ~]# wget 74.125.43.105
--2009-06-10 00:52:40--  http://74.125.43.105/
Connecting to 74.125.43.105:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: `index.html'

    [ <=>                                  ] 5,256       --.-K/s   in 0.002s 

2009-06-10 00:52:40 (2.21 MB/s) - `index.html' saved [5256]
Comment 1 Niels Haase 2009-06-17 06:51:59 EDT
Thanks for filling this bug. Unfortunately, I'm not able to reproduce them. I have no idea what's going wrong here. My first intention is to change your DNS server ip. Can you please try it with the DNS server ip of your internet provider instant of 192.168.2.1 or try this one [1] if you are unsure what the correct is.

[1]: https://www.opendns.com/start/device/ubuntu

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Tom Stocker 2009-06-17 13:49:11 EDT
Hi Niels

Indeed, changing Network Managers DNS entry - using the DHCP adresses only feature - to the first DNS server from my ISP (195.186.1.162, swisscom) did help. (remark: adding 208.67.222.222 makde it ultraslow, but worked too)

BUT: it worked before on all installations up to F10 and all other network connectivity on my home LAN by using the standard forwarder on the router provided by DHCP on the router. which used obviously the same IP as a simple DNS forwarder. So I think this is really a unwanted behaviour in F11, rather than escalating it to swisscom.

Opinion? Reason for this behaviour? is it unwanted or not?

thanks.
Comment 3 Niels Haase 2009-06-19 17:56:00 EDT
Well, I'm so far not able to reproduce the bug, on the other hand, no other user has reported this regression AFAIK. To exclude that this is not caused by some misconfiguration, can you please try the F11 Live CD [1] to see if you're seeing the same behaviour?

[1]: http://download.fedoraproject.org/pub/fedora/linux/releases/11/Live/i686/Fedora-11-i686-Live.iso

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Niels Haase 2009-06-27 08:09:24 EDT
*** Bug 508423 has been marked as a duplicate of this bug. ***
Comment 5 dyland.desmarais 2009-06-27 14:17:21 EDT
I can confirm I have the same issue.  Various apps (Yum, firefox, pidgen, playonlinux etc)  cannot seem to resolve
dns searches.  

---
[root@enterprise dyland]# yum update
Loaded plugins: fastestmirror, presto, protectbase, refresh-packagekit
Loading mirror speeds from cached hostfile
Error: Cannot retrieve metalink for repository: fedora. Please verify its path
and try again
---

Additional information:  
Attempting to reach download.fedoraproject.org or mirror.fedoraproject.org via
lynx or firefox returns a "unable to connect to remote host" error.

Diagnostic 1:  

Both download and mirror respond to ping.

---
[root@enterprise yum.repos.d]# ping download.fedoraproject.org
PING wildcard.fedoraproject.org (209.132.176.120) 56(84) bytes of data.
64 bytes from wildcard.fedoraproject.org (209.132.176.120): icmp_seq=1 ttl=106
time=1068 ms
64 bytes from wildcard.fedoraproject.org (209.132.176.120): icmp_seq=2 ttl=106
time=111 ms
64 bytes from wildcard.fedoraproject.org (209.132.176.120): icmp_seq=3 ttl=106
time=111 ms
^C
--- wildcard.fedoraproject.org ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2610ms
rtt min/avg/max/mdev = 111.661/430.710/1068.652/451.093 ms, pipe 2

[root@enterprise yum.repos.d]# ping mirrors.fedoraproject.org
PING wildcard.fedoraproject.org (209.132.176.120) 56(84) bytes of data.
64 bytes from wildcard.fedoraproject.org (209.132.176.120): icmp_seq=1 ttl=106
time=112 ms
64 bytes from wildcard.fedoraproject.org (209.132.176.120): icmp_seq=2 ttl=106
time=113 ms
---

Both firefox and lynx can reach these sites via ip.  URL address still fails. 
This indicates DNS issue.

Diagnostic 2: 
Confirm dns settings are correct

---
[root@enterprise yum.repos.d]# cat /etc/resolv.conf
# Generated by NetworkManager
domain cg.shawcable.net
search cg.shawcable.net
nameserver 64.56.129.2
nameserver 72.13.161.10


[root@enterprise yum.repos.d]# dig www.intel.com @64.56.129.2

; <<>> DiG 9.6.1rc1-RedHat-9.6.1-0.4.rc1.fc11 <<>> www.intel.com @64.56.129.2
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33668
;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.intel.com.   IN A

;; ANSWER SECTION:
www.intel.com.  6195 IN CNAME www.intel.com.edgesuite.net.
www.intel.com.edgesuite.net. 2941 IN CNAME www.intel-sino.com.edgesuite.net.
www.intel-sino.com.edgesuite.net. 20941 IN CNAME
www.intel-sino.com.edgesuite.net.chinaredirector.akadns.net.
www.intel-sino.com.edgesuite.net.chinaredirector.akadns.net. 2941 IN CNAME
a961.g.akamai.net.
a961.g.akamai.net. 20 IN A 72.247.244.34
a961.g.akamai.net. 20 IN A 72.247.244.32

;; Query time: 61 msec
;; SERVER: 64.56.129.2#53(64.56.129.2)
;; WHEN: Thu Jun 25 21:27:11 2009
;; MSG SIZE  rcvd: 231
Comment 6 dyland.desmarais 2009-06-27 14:19:28 EDT
For the request in comment #3 to try the live cd, it works.

This issue does not appear until after the first yum update after the new install and in my case, about 2 days after.

I've attempted a complete wipe and reinstall of F11 (using dvd iso) and results are the same.

[root@enterprise dyland]# uname -a
Linux enterprise 2.6.29.4-167.fc11.x86_64 #1 SMP Wed May 27 17:27:08 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux


[root@enterprise dyland]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1D:60:D5:91:BE  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:29 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:40 errors:0 dropped:0 overruns:0 frame:0
          TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7012 (6.8 KiB)  TX bytes:7012 (6.8 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:15:AF:38:0E:9B  
          inet addr:192.168.1.102  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:530857 errors:0 dropped:0 overruns:0 frame:0
          TX packets:452340 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:557090423 (531.2 MiB)  TX bytes:60535939 (57.7 MiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-15-AF-38-0E-9B-10-29-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)


[root@enterprise dyland]# cat /etc/resolv.conf
# Generated by NetworkManager
domain cg.shawcable.net
search cg.shawcable.net
nameserver 64.56.129.2
nameserver 72.13.161.10
Comment 7 Karol Trzcionka 2009-06-28 07:25:56 EDT
I found two ways to resolve it.

First:
install nss-mdns (I have installed only i586 on fedora x86_64, should be installed x86_64 too)
yum install nss-mdns

Second:
edit /etc/nsswitch.conf
Change line:
hosts:      files mdns4_minimal [NOTFOUND=return] dns
to:
hosts:      files mdns4_minimal dns
Comment 8 dyland.desmarais 2009-06-28 14:51:28 EDT
Karol's fix in Comment 7 worked for me.  In installed nss-mdns via yum, made the changes to nsswitch.conf, removed the static entries from my hosts file and rebooted.

Everything is working now as it should, all software is resolving.

Many thanks Karol.

BTW . . . can someone explain what broke?

Dyland
Comment 9 MartinG 2009-06-29 15:16:20 EDT
I see this too, on Fedora Rawhide (x86_64): 
Firefox, Konqueror, Kontact etc are not able to resolve DNS after last Rawhide update Jun 26. 

Interestingly, Opera does work. Even more interesting (maybe) is that I have had dns problems with Opera in F10 and F11 after resume - these problems are now gone.

I have nss-mdns-0.10-7.fc11.i586 (no x86_64). As yum doesn't work, I'll try to find nss-mdns 64-bit from koji and install manually to see if the workaround works for me - editing /etc/nsswitch.conf alone didn't help.
Comment 10 MartinG 2009-06-29 16:23:50 EDT
After installing nss-mdns-0.10-7.fc11.x86_64.rpm, editing /etc/nsswitch.conf, and rebooting it works for me too. However, rpc.idmapd runs at 100% CPU continously (as it did before these changes).

Any hints on what was/is the cause for all this would be appreciated.
Comment 11 jdegraw 2009-07-02 19:13:15 EDT
Iam having the same issue on a system I installed and want to chime in with some info.

I used the fedora 11 cd for x86-64 for install. Same disk as my home system that gets its connection from comcast and I have no problems what so ever. I did an update (yum -y update) and rebooted and still no issues. Everything runs fine on my home system.

Now, On system2 I built using gigabyte MB/AMD dual core at another location also on comcast I had the same outcome. No problems what so ever. Just like my home system.

Then--- I installed an exact same system as system2 but gets its connection from AT&T DSL (yahoo, Ill call it system3). System3 is connected to a motorola dsl box (model 2210-02) and I did NOT do any updating. What I found was I can surf the net ok with firefox but I cannot do any yum updates. Yum errors out with the mentioned error message. I have tried to add fedora to the hosts file and doing a yum update but I get alot of errors for sites being busy. So, Its not really a fix.

/etc/nsswitch.conf file contains the line: hosts: files dns

This is the same line that is in the nsswitch.conf file of the other boxes that work fine.
Comment 12 Daniel Lindgren 2009-07-08 07:56:42 EDT
I'm also having problems with name resolution in FC11 x86_64, some applications can't resolve names that clearly are resolvable.

Example, "zalmix" is FC11 Final x86_64:

[dali@zalmix ~]$ cat /etc/resolv.conf 
search lindgren.loc
nameserver 85.11.1.11
[dali@zalmix ~]$ nslookup www.centos.org
Server:		85.11.1.11
Address:	85.11.1.11#53

Non-authoritative answer:
Name:	www.centos.org
Address: 72.232.194.162

[dali@zalmix ~]$ telnet www.centos.org 80
telnet: www.centos.org: Temporary failure in name resolution
www.centos.org: Host name lookup failure

I do the same from a CentOS 5 (x86_64) machine on the same net, with identical resolv.conf:

[dali@chieftec ~]$ cat /etc/resolv.conf 
search lindgren.loc
nameserver 85.11.1.11 
[dali@chieftec ~]$ nslookup www.centos.org
Server:		85.11.1.11
Address:	85.11.1.11#53

Non-authoritative answer:
Name:	www.centos.org
Address: 72.232.194.162

[dali@chieftec ~]$ telnet www.centos.org 80
Trying 72.232.194.162...
Connected to www.centos.org (72.232.194.162).
Escape character is '^]'.

...

I previously used FC11 Preview (x86_64) with very little problems, reinstalled the machine 3 days ago with FC11 Final (x86_64) from DVD and the problems began. I dual boot the same machine with an OS from a well known Redmond-based company and have no problems then.

I have tried deactivatin SELinux, no difference.

Firefox and telnet can't find www.centos.org, nslookup does. For some strange reason some addresses work:

[dali@zalmix ~]$ nslookup start.fedoraproject.org
Server:		85.11.1.11
Address:	85.11.1.11#53

Non-authoritative answer:
start.fedoraproject.org	canonical name = wildcard.fedoraproject.org.
Name:	wildcard.fedoraproject.org
Address: 66.35.62.166

[dali@zalmix ~]$ telnet start.fedoraproject.org 80
Trying 66.35.62.166...
Connected to start.fedoraproject.org.
Escape character is '^]'.
Comment 13 Tom Stocker 2009-07-08 08:05:12 EDT
I can confirm this bug using the live CD.

What is the status of the bug? actions? info required?
Comment 14 Daniel Lindgren 2009-07-08 09:06:32 EDT
Update:

Changed to a local DNS server (the CentOS machine) in resolv.conf on my FC11 x86_64-machine, the problem went away. Both telnet and Firefox work.

Changed back to external (ISP) DNS server in resolv.conf, problem reappeared.
Comment 15 Daniel Lindgren 2009-07-12 06:29:41 EDT
Is there any more info required? There seems to be a serious problem with basic name resolution in FC11 x86_64, yet there is no activity (reported) in this bug report?

I'd be happy to assist with debug info, just tell me what's needed.
Comment 16 Peter L 2009-07-12 11:33:36 EDT
I have this problem with F11 i586. It's not restricted to x86_64.

Just to confirm what I see...
1 Install from Live CD
2 Confirm that DNS server points to DNS server on my local router, which works fine with Windows, Ubuntu 9.04 and earlier versions of Fedora
3 Open Firefox
4 Enter a URL with a DNS name
5 Firefox fails to load the page with a "Server not found" error
6 Enter a URL with an IP address, Firefox successfully loads the page
7 Try an "nslookup" - works fine
8 Do a full "yum update" as of today
9 Repeat from 3 above - same results
10 Open NetworkManager
11 Select "Automatic DHCP (addresses only)" and enter DNS servers for my ISP, or OpenDNS
12 Enter a URL with a DNS name in Firefox
13 Page loads successfully.

So it seems to be a problem with using the DNS server on my router, which is an aging Alcatel Speedtouch 510. Note that the fixes above with nss-mdns and editing /etc/nsswitch.conf did not help for me, but I didn't confirm this with restarts of the machine.
Comment 17 Niels Haase 2009-07-14 18:04:37 EDT
Please find a workaround at: http://www.fedorafaq.org/f10/#dns-slow

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 505105 ***
Comment 18 Daniel Lindgren 2009-07-15 03:14:37 EDT
I've tried the above workaround without improvement. I use static IP's, don't know if the workaround still applies.

If I use my local DNS server in resolv.conf, no problems in any application (that I've tested).

If I use my ISP's DNS in resolv.conf, name resolution in telnet and Firefox stops working (for most addresses, I use www.centos.org for testing). Nslookup still works.

Other operating systems on my network (e g CentOS 5.3, Windows 7 RC) have no problems using my ISP's DNS in resolv.conf.

I'm using FC11 x86_64 for testing, fresh install with updates.
Comment 19 dyland.desmarais 2009-07-15 15:00:06 EDT
(In reply to comment #18)
> I've tried the above workaround without improvement. I use static IP's, don't
> know if the workaround still applies.
> 

> I'm using FC11 x86_64 for testing, fresh install with updates.  

Have you tried the suggested fix in comment 7?  I'm running FC11 x86_64 and it fixed my issues.

Dyland
Comment 20 Daniel Lindgren 2009-07-16 03:25:56 EDT
> Have you tried the suggested fix in comment 7?  I'm running FC11 x86_64 and it
> fixed my issues.

I already have a workaround (local DNS server). I tried the workaround in #17 because it seemed unrelated, and it was (in my case).

I'm not sure I completely understand what the root cause is (a change in glibc?), but I'm hoping there will be a permanent fix for this instead of a bunch of workarounds.

Comment #17 indicated that this has been an issue since FC10, which kind of made me wonder if FC is the right distro for me ... serious bugs in basic functions like name resolution should not survive to the next release.

Perhaps Debian is making the right choice by replacing glibc with eglibc (http://blog.aurel32.net/?p=47).
Comment 21 Tom Stocker 2009-07-16 08:02:22 EDT
in fact it seems to be a problem with the glibc, or more precice with the way, a nameserver lookup works. read the whole details here:

https://bugzilla.redhat.com/show_bug.cgi?id=505105

installing the glibc mentioned there (2.10.1-3, the F11 one, altough the one from F12 *should* work too) resolved my problem as far that i can tell for now. I'll test it on my homelan this evening (with a motorola VDSL modem, which seems to be somewhat misbehaving)

Please note that this bug is marked as a duplicate from bug 505105 and therefore closed.
Comment 22 Scott Robbins 2009-07-21 06:13:11 EDT
I believe this should be reopened, as I don't think it's a duplicate of 505105 which seems to have something to do with glibc. 

This issue, judging from the description, (and there's probably a duplicate bug somewhere, but I can't find it.) I see similar descriptions and I know that Will Woods noticed it with Wine and determined the cause.  


http://rawhidewatch.wordpress.com/2009/07/09/rawhide-x86_64-dns-broken-nss-mdns-multilib-issue/


The problem occurs if you have an x86_64 bit system, do NOT have nss-mdns installed and then install Wine, the Google Chromium browser (from a 3rd party repository) or any i586 only program that pulls in nss-mdns. 

The fix is to comment out the line in /etc/nssswitch.com line referring to mdns, which will fix things, then install nss-mdns, which will, on a 64 bit system, pull in the 64 bit nss-mdns packge.  Having that will fix the issue.
Comment 23 Niels Haase 2009-07-21 08:27:14 EDT
(In reply to comment #22)
> I believe this should be reopened, as I don't think it's a duplicate of 505105
> which seems to have something to do with glibc. 
> 
I agree with this. Therefore reopen and assigen to nss-mdns component.
 


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 24 Daniel Lindgren 2009-07-22 11:04:38 EDT
> I agree with this. Therefore reopen and assigen to nss-mdns component.

The problems I have do not seem to be related to nss-mdns, this is what happens when I use my ISP:s DNS server:

[root@testburk ~]# rpm -q nss-mdns
package nss-mdns is not installed
[root@testburk ~]# nslookup www.centos.org
Server:         85.11.1.11
Address:        85.11.1.11#53

Non-authoritative answer:
Name:   www.centos.org
Address: 72.232.194.162

[root@testburk ~]# telnet www.centos.org 80
telnet: www.centos.org: Temporary failure in name resolution
www.centos.org: Host name lookup failure

Change DNS server to a local DNS server (BIND):

[root@testburk ~]# nslookup www.centos.org
Server:         192.168.100.10
Address:        192.168.100.10#53

Non-authoritative answer:
Name:   www.centos.org
Address: 72.232.194.162

[root@testburk ~]# telnet www.centos.org 80
Trying 72.232.194.162...
Connected to www.centos.org.
Escape character is '^]'.
[...]

There is a firewall (with a DNS proxy) between me and my ISP:s DNS. This problem surfaced about a month ago, had no problems before that. My Debian, CentOS and Windows machines can use my ISP:s DNS for name resolution, only FC11 (x86_64, vanilla install, all updates applied) has this issue.
Comment 25 Lennart Poettering 2009-07-22 19:08:15 EDT

*** This bug has been marked as a duplicate of bug 508481 ***
Comment 26 Peter Schultz 2009-09-15 03:05:23 EDT
This Error occurs also on RHEL 5.3 AS and ES - we filled an Case at RHN