Bug 508423 - All system and application dns queries (firefox, lynx, yum playonlinux, google talk etc) are not resolving
All system and application dns queries (firefox, lynx, yum playonlinux, googl...
Status: CLOSED DUPLICATE of bug 504951
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 20:52 EDT by dyland.desmarais
Modified: 2009-06-27 08:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-27 08:09:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dyland.desmarais 2009-06-26 20:52:50 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4

Problem:  
Various apps (Yum, firefox, pidgen, playonlinux etc)  cannot seem to resolve dns searches.  For the purpose of this bug I am going to focus on yum.  I cannot reach any repository.  Returned error is as follows:

---
[root@enterprise dyland]# yum update
Loaded plugins: fastestmirror, presto, protectbase, refresh-packagekit
Loading mirror speeds from cached hostfile
Error: Cannot retrieve metalink for repository: fedora. Please verify its path and try again
---

Additional information:  
Attempting to reach download.fedoraproject.org or mirror.fedoraproject.org via lynx or firefox returns a "unable to connect to remote host" error.

Diagnostic 1:  

Both download and mirror respond to ping.

---
[root@enterprise yum.repos.d]# ping download.fedoraproject.org
PING wildcard.fedoraproject.org (209.132.176.120) 56(84) bytes of data.
64 bytes from wildcard.fedoraproject.org (209.132.176.120): icmp_seq=1 ttl=106 time=1068 ms
64 bytes from wildcard.fedoraproject.org (209.132.176.120): icmp_seq=2 ttl=106 time=111 ms
64 bytes from wildcard.fedoraproject.org (209.132.176.120): icmp_seq=3 ttl=106 time=111 ms
^C
--- wildcard.fedoraproject.org ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2610ms
rtt min/avg/max/mdev = 111.661/430.710/1068.652/451.093 ms, pipe 2

[root@enterprise yum.repos.d]# ping mirrors.fedoraproject.org
PING wildcard.fedoraproject.org (209.132.176.120) 56(84) bytes of data.
64 bytes from wildcard.fedoraproject.org (209.132.176.120): icmp_seq=1 ttl=106 time=112 ms
64 bytes from wildcard.fedoraproject.org (209.132.176.120): icmp_seq=2 ttl=106 time=113 ms
---

Both firefox and lynx can reach these sites via ip.  URL address still fails.  This indicates DNS issue.

Diagnostic 2: 
Confirm dns settings are correct

---
[root@enterprise yum.repos.d]# cat /etc/resolv.conf
# Generated by NetworkManager
domain cg.shawcable.net
search cg.shawcable.net
nameserver 64.56.129.2
nameserver 72.13.161.10


[root@enterprise yum.repos.d]# dig www.intel.com @64.56.129.2

; <<>> DiG 9.6.1rc1-RedHat-9.6.1-0.4.rc1.fc11 <<>> www.intel.com @64.56.129.2
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33668
;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.intel.com.			IN	A

;; ANSWER SECTION:
www.intel.com.		6195	IN	CNAME	www.intel.com.edgesuite.net.
www.intel.com.edgesuite.net. 2941 IN	CNAME	www.intel-sino.com.edgesuite.net.
www.intel-sino.com.edgesuite.net. 20941	IN CNAME www.intel-sino.com.edgesuite.net.chinaredirector.akadns.net.
www.intel-sino.com.edgesuite.net.chinaredirector.akadns.net. 2941 IN CNAME a961.g.akamai.net.
a961.g.akamai.net.	20	IN	A	72.247.244.34
a961.g.akamai.net.	20	IN	A	72.247.244.32

;; Query time: 61 msec
;; SERVER: 64.56.129.2#53(64.56.129.2)
;; WHEN: Thu Jun 25 21:27:11 2009
;; MSG SIZE  rcvd: 231
---

Confirmed correct dns server addresses and they are functioning.

Diagnostic 3:  
Statically assigned ip in the hosts file and then ran yum update

---
[root@enterprise yum.repos.d]# cat /etc/hosts
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

209.132.176.120 download.fedoraproject.org
209.132.176.120 mirrors.fedoraproject.org

192.150.18.37 linuxdownload.adobe.com
193.28.235.40 rpm.livna.org

193.28.235.60 download1.rpmfusion.org
213.129.242.84 mirrors.rpmfusion.org 
---

Yum updates now work

Conclusion: Something is interfering with fedora 11 functions from accessing dns in the protocol stack (my best guest).


Note: Firefox was fixed by going to about:config and changing 

network.dns.disableIPv6 = TRUE

I suspect the underlying ipv6 functions may be interfering if Firefox is any indication.

Reproducible: Always

Steps to Reproduce:
Unknown.  Install (dvd iso) and first yum update provided no problems.  System worked fine first couple of days.
Actual Results:  
n/a  A number of yum issues have appeared on the Fedora Forum which have been resolved with the instructions found here:

http://digitizor.com/2009/06/17/how-to-fix-the-cannot-retrieve-repository-metadata-repomd-xml-error-in-fedora-11/

I believe this fix is a workaround for the bug I'm reporting

Expected Results:  
all software should resolve ip addresses via dns.

[root@enterprise ~]# uname -a
Linux enterprise 2.6.29.4-167.fc11.x86_64 #1 SMP Wed May 27 17:27:08 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Niels Haase 2009-06-27 08:09:24 EDT
Thank you for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 504951 ***

Note You need to log in before you can comment on or make changes to this bug.