Bug 513778

Summary: Regression: 2.6.29.6-213 causes "snd_pcm_avail() returned a value that is exceptionally large"
Product: [Fedora] Fedora Reporter: Tethys <sta040>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: abu_hurayrah, itamar, kernel-maint, lkundrak, talcite
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-07-27 23:57:50 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Tethys 2009-07-25 14:12:11 EDT
Description of problem:
When playing audio with xmms, the audio will play fine for a while, and
then start skipping forward, making it unlistenable, and leaving entries
like this in /var/log/messages:

snd_pcm_avail() returned a value that is exceptionally large: 18446744073709544844 bytes (418293516372 ms).


Version-Release number of selected component (if applicable):
kernel-2.6.29.6-213.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Boot into kernel-2.6.29.6-213.fc11.x86_64
2. Play audio with xmms
3.

Additional info:

This problem has only existed since the 2.6.29.6-213 kernel upgrade
(I didn't upgrade any other packages on the system). If I boot back
into 2.6.29.5-191, the problem disappears.

Hardware details:
http://www.smolts.org/client/show/pub_a8cea266-ccd1-4cbf-9b6f-7033ec7910fa

Full log message:
Jul 25 16:45:40 leto pulseaudio[4540]: alsa-sink.c: Increasing wakeup watermark to 30.00 ms
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 18446744073709544844 bytes (418293516372 ms).
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c: snd_pcm_dump():
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subdevice 0
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c: Its setup is:
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   stream       : PLAYBACK
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   format       : S16_LE
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   subformat    : STD
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   channels     : 2
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   rate         : 44100
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   exact rate   : 44100 (44100/1)
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   msbits       : 16
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   buffer_size  : 16384
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   period_size  : 16384
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   period_time  : 371519
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   tstamp_mode  : ENABLE
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   period_step  : 1
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   avail_min    : 16384
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   period_event : 0
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   start_threshold  : -1
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   stop_threshold   : 4611686018427387904
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   silence_threshold: 0
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   silence_size : 0
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   boundary     : 4611686018427387904
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   appl_ptr     : 9782942
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   hw_ptr       : 9764865
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: 335980 bytes (1904 ms).
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c: snd_pcm_dump():
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subdevice 0
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c: Its setup is:
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   stream       : PLAYBACK
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   format       : S16_LE
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   subformat    : STD
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   channels     : 2
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   rate         : 44100
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   exact rate   : 44100 (44100/1)
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   msbits       : 16
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   buffer_size  : 16384
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   period_size  : 16384
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   period_time  : 371519
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   tstamp_mode  : ENABLE
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   period_step  : 1
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   avail_min    : 16384
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   period_event : 0
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   start_threshold  : -1
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   stop_threshold   : 4611686018427387904
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   silence_threshold: 0
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   silence_size : 0
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   boundary     : 4611686018427387904
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   appl_ptr     : 9849092
Jul 25 16:45:41 leto pulseaudio[4540]: alsa-util.c:   hw_ptr       : 9765097
Jul 25 16:45:45 leto pulseaudio[4540]: ratelimit.c: 6174 events suppressed
Jul 25 16:45:50 leto pulseaudio[4540]: ratelimit.c: 11478 events suppressed
Jul 25 16:45:55 leto pulseaudio[4540]: ratelimit.c: 14864 events suppressed
Jul 25 16:46:00 leto pulseaudio[4540]: cpulimit.c: Received request to terminate due to CPU overload.
Comment 1 Matt Chan 2009-07-26 23:57:37 EDT
*** Bug 513886 has been marked as a duplicate of this bug. ***
Comment 2 Lubomir Rintel 2009-07-27 23:57:50 EDT

*** This bug has been marked as a duplicate of bug 506075 ***