This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 514610

Summary: 0.107(x86_64) won't boot: BUG at drivers/gpu/drm/drm_gem.c:451! invalid opcode: 0000 [#1] SMP
Product: [Fedora] Fedora Reporter: Tom London <selinux>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: rawhideCC: awilliam, itamar, jlaska, kernel-maint, zaitcev
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-07-31 15:18:49 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 507676    
Attachments:
Description Flags
Screenshot of "invalid opcode" trace during boot none

Description Tom London 2009-07-29 16:23:10 EDT
Created attachment 355608 [details]
Screenshot of "invalid opcode" trace during boot

Description of problem:
kernel-2.6.31-0.107.rc4.git3.fc12.x86_64 quickly crashes during boot on my Thinkpad X200.

I attach a screenshot of the BUG text; I'll attempt to copy a few lines here:

kernel BUG at drivers/gpu/drm/drm_gem.c:425!
invalid opcode: 0000 [#1] SMP
last sysfs file: /sys/modules/drm/initstate
CPU 0
Modules linked in: i915(*) drm i2c_algo_bit i2c_core video output
Pid: 82, comm: work_for_cpu Not tainted 2.6.31-0.107.rc4.git3.fc12.x86_64 #1 74585FU
<<<<SNIP>>>>
Call Trace:
drm_gem_object_free+0x0/0x86 [drm]
kref_put+0x56/0x76
drm_gem_cleanup_ringbuffer+0x52/0x86 [i915]
i915_driver_load_0xa9c/0xb1c [i915]
drm_get_dev+0x369/0x4d0 [drm]
<<<SNIP>>>

Happens every time.

If I boot with "nomodeset", I seem to get a black screen when the gdm session screen should be displayed.....

Version-Release number of selected component (if applicable):
kernel-2.6.31-0.107.rc4.git3.fc12.x86_64

How reproducible:
Every boot

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-07-29 16:31:38 EDT
/var/log/messages from boot with "nomodeset" shows this:

Jul 29 13:04:21 tlondon dhclient: bound to 10.11.16.190 -- renewal in 246159 seconds.
Jul 29 13:04:22 tlondon kernel: ------------[ cut here ]------------
Jul 29 13:04:22 tlondon kernel: kernel BUG at kernel/timer.c:619!
Jul 29 13:04:22 tlondon kernel: invalid opcode: 0000 [#1] SMP 
Jul 29 13:04:22 tlondon kernel: last sysfs file: /sys/devices/virtual/backlight/acpi_video0/brightness
Jul 29 13:04:22 tlondon kernel: CPU 1 
Jul 29 13:04:22 tlondon kernel: Modules linked in: sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath kvm_intel kvm uinput usblp usb_storage arc4 snd_hda_codec_conexant ecb snd_hda_intel snd_hda_codec i2c_i801 thinkpad_acpi hwmon iTCO_wdt snd_hwdep iTCO_vendor_support wmi iwlagn iwlcore mac80211 snd_pcm snd_timer snd cfg80211 soundcore snd_page_alloc rfkill e1000e i915 drm i2c_algo_bit i2c_core video output [last unloaded: microcode]
Jul 29 13:04:22 tlondon kernel: Pid: 1300, comm: Xorg Not tainted 2.6.31-0.107.rc4.git3.fc12.x86_64 #1 74585FU
Jul 29 13:04:22 tlondon kernel: RIP: 0010:[<ffffffff81072fb3>]  [<ffffffff81072fb3>] __mod_timer+0x3d/0x13b
Jul 29 13:04:22 tlondon kernel: RSP: 0018:ffff880135519bf8  EFLAGS: 00010246
Jul 29 13:04:22 tlondon kernel: RAX: 0000000000000000 RBX: ffff880134fc51b0 RCX: 0000000000000000
Jul 29 13:04:22 tlondon kernel: RDX: 0000000000000000 RSI: 00000000fffc0c84 RDI: ffff880134fc51b0
Jul 29 13:04:22 tlondon kernel: RBP: ffff880135519c48 R08: ffffffff8176a158 R09: 000000003cb61b38
Jul 29 13:04:22 tlondon kernel: R10: ffffffff81d36628 R11: 000000003cb61b38 R12: 00000000fffc0c84
Jul 29 13:04:22 tlondon kernel: R13: ffff88012755fbd8 R14: ffff88012755fbd8 R15: 0000000000000000
Jul 29 13:04:22 tlondon kernel: FS:  00007f81facc47b0(0000) GS:ffff88002efde000(0000) knlGS:0000000000000000
Jul 29 13:04:22 tlondon kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Jul 29 13:04:22 tlondon kernel: CR2: 00000000021c8378 CR3: 000000013486d000 CR4: 00000000000026e0
Jul 29 13:04:22 tlondon kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Jul 29 13:04:22 tlondon kernel: DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Jul 29 13:04:22 tlondon kernel: Process Xorg (pid: 1300, threadinfo ffff880135518000, task ffff880121c8c940)
Jul 29 13:04:22 tlondon kernel: Stack:
Jul 29 13:04:22 tlondon kernel: ffff880135519c48 ffffff0081289d93 ffffffff000000f0 000000003cb61b38
Jul 29 13:04:22 tlondon kernel: <0> ffff880135519c68 ffff880134fc4090 00000000fffc0a90 ffff88012755fbd8
Jul 29 13:04:22 tlondon kernel: <0> ffff88012755fbd8 ffff8801371ee210 ffff880135519c68 ffffffff810731df
Jul 29 13:04:22 tlondon kernel: Call Trace:
Jul 29 13:04:22 tlondon kernel: [<ffffffff810731df>] mod_timer+0x33/0x49
Jul 29 13:04:22 tlondon kernel: [<ffffffffa0064bbb>] intel_increase_renderclock+0x168/0x183 [i915]
Jul 29 13:04:22 tlondon kernel: [<ffffffffa0067e27>] intel_mark_busy+0x41/0xda [i915]
Jul 29 13:04:22 tlondon kernel: [<ffffffffa005e46b>] i915_gem_set_domain_ioctl+0x96/0x109 [i915]
Jul 29 13:04:22 tlondon kernel: [<ffffffffa005e3d5>] ? i915_gem_set_domain_ioctl+0x0/0x109 [i915]
Jul 29 13:04:22 tlondon kernel: [<ffffffffa0027afc>] drm_ioctl+0x23d/0x2fd [drm]
Jul 29 13:04:22 tlondon kernel: [<ffffffff8122c815>] ? avc_has_perm+0x6b/0x91
Jul 29 13:04:22 tlondon kernel: [<ffffffff81150bb4>] vfs_ioctl+0x7e/0xaa
Jul 29 13:04:22 tlondon kernel: [<ffffffff81151129>] do_vfs_ioctl+0x4aa/0x506
Jul 29 13:04:22 tlondon kernel: [<ffffffff811511ea>] sys_ioctl+0x65/0x9c
Jul 29 13:04:22 tlondon kernel: [<ffffffff81012f42>] system_call_fastpath+0x16/0x1b
Jul 29 13:04:22 tlondon kernel: Code: 1f 44 00 00 48 89 fb 49 89 f4 41 89 cf 65 48 8b 04 25 28 00 00 00 48 89 45 c8 31 c0 88 55 bc e8 86 ff ff ff 48 83 7b 18 00 75 04 <0f> 0b eb fe 48 8d 75 c0 48 89 df e8 e8 f5 ff ff 48 83 3b 00 49 
Jul 29 13:04:22 tlondon kernel: RIP  [<ffffffff81072fb3>] __mod_timer+0x3d/0x13b
Jul 29 13:04:22 tlondon kernel: RSP <ffff880135519bf8>
Jul 29 13:04:22 tlondon kernel: ---[ end trace 721ab046447793f3 ]---
Jul 29 13:04:22 tlondon nscd: 1311 Access Vector Cache (AVC) started
Jul 29 13:04:22 tlondon NetworkManager: <info>  (eth0): device state change: 7 -> 8 (reason 0)
Comment 2 Tom London 2009-07-29 16:52:39 EDT
Also, output of "lspci":

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
Comment 3 James Laska 2009-07-30 09:24:40 EDT
Seeing this as well on:

* 00:02.0 VGA compatible controller: Intel Corporation 82G965 Integrated Graphics
Controller (rev 02) 

Adding to F12Alpha for consideration
Comment 4 Tom London 2009-07-30 23:14:26 EDT
kernel-2.6.31-0.112.rc4.git3.fc12.x86_64 "boots for me".

Issue known?
Comment 5 Adam Williamson 2009-07-31 12:09:18 EDT
James, please test 112 and confirm whether this is fixed for you, as per blocker bug discussion meeting.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 James Laska 2009-07-31 14:48:30 EDT
No longer seeing the problem reported in this issue on the same system.  However, I am now seeing bug#514600.  Will track the KMS problem in that bug.
Comment 7 James Laska 2009-07-31 14:55:51 EDT
Comment#6 was also using kernel-2.6.31-0.112.rc4.git3.fc12
Comment 8 Adam Williamson 2009-07-31 15:18:49 EDT
Let's close this one, then.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Pete Zaitcev 2009-07-31 17:47:41 EDT
*** Bug 514981 has been marked as a duplicate of this bug. ***