Bug 515998

Summary: Errors installing gdb-6.8.50.20090302-21.fc11.i586 with --excludedocs
Product: [Fedora] Fedora Reporter: Alexander Todorov <atodorov>
Component: gdbAssignee: Jan Kratochvil <jan.kratochvil>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: jan.kratochvil
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: gdb-7.0-4.fc12 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-23 18:31:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 516757    

Description Alexander Todorov 2009-08-06 11:33:42 UTC
Description of problem:
When installing with --excludedocs there are errors caused by missing files.

Version:
gdb-6.8.50.20090302-21.fc11.i586

How reproducible:
Always

Steps to reproduce:
1) rpm -ihv --excludedocs gdb-6.8.50.20090302-21.fc11.i586  

or:
- use %packages --excludedocs in kickstart
- enable %_excludedocs macro in RPM

Expected results:
Package is installed without errors

Actual results:
Error(s): Installing gdb-6.8.50.20090302-21.fc11.i586
install-info: No such file or directory for /usr/share/info/annotate.info.gz
install-info: No such file or directory for /usr/share/info/gdb.info.gz
install-info: No such file or directory for /usr/share/info/gdbint.info.gz
install-info: No such file or directory for /usr/share/info/stabs.info.gz

Additional info:
This bug is automatically filed with python-bugzilla and component assignment may be incorrect.

Comment 1 Jan Kratochvil 2009-08-11 19:06:27 UTC
https://www.redhat.com/archives/fedora-packaging/2009-August/thread.html#00028

How/if to do the fix is so far not resolved.

Comment 2 Jan Kratochvil 2009-10-23 18:31:33 UTC
https://www.redhat.com/archives/fedora-devel-list/2009-August/msg00311.htmlPlease postpone fixing scriptlets for this issue until some
conclusion gets reached on fedora-packaging-list.

It was never withdrawn but I do not see any problems with it now.

Comment 3 Fedora Update System 2009-11-25 10:53:21 UTC
gdb-7.0-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gdb-7.0-7.fc12

Comment 4 Fedora Update System 2009-11-27 21:59:00 UTC
gdb-7.0-7.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.