Bug 521266

Summary: Fix instances of #!/usr/bin/env python in createrepo
Product: Red Hat Enterprise Linux 5 Reporter: Issue Tracker <tao>
Component: createrepoAssignee: Packaging Maintenance Team <packaging-team-maint>
Status: CLOSED NEXTRELEASE QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.4CC: cww, james.antill, mpoole, tao
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 623105 (view as bug list) Environment:
Last Closed: 2013-03-14 20:05:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 502912, 590060, 521940    

Description Issue Tracker 2009-09-04 15:32:46 UTC
Escalated to Bugzilla from IssueTracker

Comment 1 Issue Tracker 2009-09-04 15:32:47 UTC
Event posted on 09-04-2009 11:31am EDT by kbaxley

THere's a project underway in Fedora 12 to finally resolve the issues with Red Hat including #!/usr/bin/env python in our python executables:

https://fedoraproject.org/wiki/Features/SystemPythonExecutablesUseSystemPython

There's also a Fedora bug opened on this, and comments in there state that this is a big priority for RHEL6:

https://bugzilla.redhat.com/show_bug.cgi?id=518994

For RHEL5, we've been instructed by Product Management to open bugs on a package-by-package basis to address the problem.

In this case, createrepo in RHEL5 has at least one python executable containing #!/usr/bin/env python
This event sent from IssueTracker by kbaxley  [LLNL (HPC)]
 issue 339029

Comment 3 RHEL Program Management 2009-11-06 19:22:18 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 5 RHEL Program Management 2010-08-09 19:42:32 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 9 RHEL Program Management 2011-05-31 15:24:11 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 12 James Antill 2013-03-14 20:05:58 UTC
I'm 99% sure this is all fixed in the latest RHEL-6 createrepo.