This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 521940 - Make RHEL5 python executables use system python binary directly
Make RHEL5 python executables use system python binary directly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: RHEL Product and Program Management
Release Test Team
: Tracking
: 467009 (view as bug list)
Depends On: 521270 456928 521266 521273 521275 521279 521280 521281 521284 521285 521289 521294 521295 521298 521300 521301 521303 521304 521306 521307 521333 521337 521338 521339 521340 521855 521857 521863 521872 521877 521878 521880 521884 521887 521888 521891 521892 521897 521898 521900 521904 521905 575965 595715 605171 623105 636825 708178 1019336
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-08 15:30 EDT by Issue Tracker
Modified: 2013-10-15 09:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 15:23:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2009-09-08 15:30:56 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2009-09-08 15:30:58 EDT
Event posted on 04-30-2009 08:36pm EDT by woodard

The problem is that when we just do /usr/bin/env python if the user including root happens to have a different path like /usr/local/ and this has a different python e.g. python 2.6 then our script might not run. 

Many scripts have been modified to call "python2.4" rather than python directly. This seems to fix many of the problems but many scripts still remain.


Date: Tue, 28 Apr 2009 12:08:31 -0400
From: Subhendu Ghosh <sghosh@redhat.com>
User-Agent: Thunderbird 2.0.0.21 (X11/20090310)
MIME-Version: 1.0
To: woodard@redhat.com
Subject: Re: languages and multi-ABI support
References: <49F09C46.2070907@redhat.com> <20090423165416.GA50047@redhat.com>   <49F0BB5C.6090406@redhat.com> <20090424140154.GD50975@redhat.com>     <49F1FB9F.1060705@redhat.com>   <alpine.LRH.2.00.0904242147360.31716@honeypot.usersys.redhat.com>    <20090427154116.GD16690@nostromo.devel.redhat.com>       <alpine.LRH.2.00.0904271143280.28608@honeypot.usersys.redhat.com>    <alpine.LRH.2.00.0904280959140.6081@honeypot.usersys.redhat.com> <E981969C-7BD2-42B4-9B82-039E29DB4E69@redhat.com>
In-Reply-To: <E981969C-7BD2-42B4-9B82-039E29DB4E69@redhat.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Scanned-By: MIMEDefang 2.58 on 172.16.27.26

woodard@redhat.com wrote:
> 
> 
> On Apr 28, 2009, at 7:00, Andrew Hecox <ahecox@redhat.com> wrote:
> 
>> On Mon, 27 Apr 2009, Andrew Hecox wrote:
>>
>>> On Mon, 27 Apr 2009, Bill Nottingham wrote:
>>>
>>>> Andrew Hecox (ahecox@redhat.com) said:
>>>>> Python 3 was released in late 2008. If we don't ship with it available
>>>>> in some means in RHEL6 GA we'll be *starting* 1.5 years behind.
>>>> And yet, nothing really uses it. Do we have actual customer requests
>>>> for this?
>>>
>>> https://bugzilla.redhat.com/show_bug.cgi?id=465950
>>>
>>> only one customer that I know of, LLNL, and they're odd-birds, at
>>> times. I can ask TAMs to ask their customers, if we're interested.
>>
>> re-iterating my offer to ask, if people are interested. Asking TAMs to
>> survey their customers isn't the most scientific way of collecting
>> market data, but it often beats 'random guess'.
>>
>> I don't want to ask if we don't care, since it's nice to not pester
>> people when their input won't get taken into account.
>>
> 
> Talked to some people here at LLNL and they aren't currently ready to
> move to Python 3 but wanted to hold open the possibility of moving to
> it. They said the most annoying thing is all the RH supplied scripts
> which use the Python idiom "env python" rather than an explicit path to
> the system RH supplied version of python. The problem is that this
> creates problems for any user who has a different version of python
> earlier in their path than the system python.

Can you file a bz for couple of scripts and cc me?

-regards
Subhendu

-- 
Subhendu Ghosh
Red Hat
Phone: +1-201-232-2851
Email: sghosh@redhat.com

This event sent from IssueTracker by kbaxley  [LLNL (HPC)]
 issue 291889
Comment 2 Issue Tracker 2009-09-08 15:30:59 EDT
Event posted on 08-28-2009 01:42pm EDT by kbaxley

Ben,

I also asked about the possibility of getting the /usr/bin/env python
fixed for RHEL5 as well.  PM is fine with doing it, but, it won't be the
big sweep like what we're going to see for RHEL6.  In the case of RHEL5,
it'll be a case of filing tickets for every package where /usr/bin/env
python is used and address things on an individual basis.  If you're up
for doing this I'll be glad to help out in any way I can.  Thanks.

> From: Subhendu Ghosh <sghosh@redhat.com>
> Date: August 27, 2009 7:58:39 PM EDT
> To: Jeremy West <jwest@redhat.com>
> Subject: Re: Fwd: porting #!/usr/bin/env python fixes to RHEL5
>
> If GSS can find the the instances and file individual BZ - that  
> would be
> easiest way to attempt to fix them ofver a couple of releases. We  
> Cannot do a
> sweep as we are doing for RHEL6.
>
> Knowing about this helps. Only after GSS mentioned it did we take a  
> look at
> this for RHEL6. :)
>
> -regards
> subhendu


This event sent from IssueTracker by kbaxley  [LLNL (HPC)]
 issue 291889
Comment 3 Charlie Wyse 2009-09-09 17:46:22 EDT
*** Bug 467009 has been marked as a duplicate of this bug. ***
Comment 4 Charlie Wyse 2009-09-09 20:17:50 EDT
The customer asked that we unlock this ticket so they can look at it and add any comments they feel helpful.  Is that possible?

Note You need to log in before you can comment on or make changes to this bug.