Bug 522388

Summary: CDDB manual search returns "301 Moved Permanently"
Product: [Fedora] Fedora Reporter: william <wzanatta>
Component: easytagAssignee: Matthias Saou <matthias>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 11CC: matthias, wzanatta
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: 2.1.6-2.fc11 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-12-28 20:07:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description william 2009-09-10 09:25:32 UTC
Description of problem:

  When doing a manual search on the gnudb.org CDDB EasyTag is returning a "301 Moved Permanently" HTTP message.

  Sometimes it returns a "302 Found" but no results at all.

  I've seen some patches around for fixing that in other distros but nothing for FC or the official release.

Version-Release number of selected component (if applicable):

  EasyTag v2.1 
  fc11 rpm: easytag-2.1-6.fc11.x86_64

How reproducible:
 
  Attempt a manual search in CDDB.

Steps to Reproduce:
1. Open EasyTag -> Misc -> CD Data Base Search ... -> Manual Search pane
2. Type the desired keywords in "Words:" field
3. click "Search" 
  
Actual results:

  Error/Warning messages but no search results

Expected results:

  CDDB search results

Additional info:

Comment 1 Matthias Saou 2009-09-12 21:22:35 UTC
I've just pushed a build of 2.1.6 to devel, and included the patch from the office sf.net downloads which should fix this. Could you please give it a try? If it works, I'll probably just push the same version for F-10 and F-11 too.

Comment 2 william 2009-09-15 21:14:14 UTC
I've tried the version you've pushed and here's the results:

  1. using "gnudb.gnudb.org" (recommended at the gnudb site) won't work.

  2. using "gnudb.org" won't work either.

  3. using "www.gnudb.org" works pretty fine.

Tested with m4a and ogg files. Now it just doesn't find the mp3 files.

I saw the patch has a bunch of IFs for "gnudb". Clearly it is a specific workaround, but seems to be working fine.

Thank you.

Comment 3 Matthias Saou 2009-12-08 09:46:59 UTC
The mp3 problem is bug #525519. I'll wait a little, then probably push the easytag update to F-11 too.

Comment 4 Fedora Update System 2009-12-08 20:11:36 UTC
easytag-2.1.6-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/easytag-2.1.6-2.fc11

Comment 5 Fedora Update System 2009-12-10 04:22:34 UTC
easytag-2.1.6-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update easytag'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-12999

Comment 6 william 2009-12-10 22:46:48 UTC
will test at home.

meanwhile, just tested eastytag-2.1.6-2.fc12 at work and seems to be working nicely.

thanks!

Comment 7 Fedora Update System 2009-12-28 20:07:54 UTC
easytag-2.1.6-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.