Bug 525519 - Can't edit mp3-tags in easytag anymore
Summary: Can't edit mp3-tags in easytag anymore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: easytag
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 536905 542267 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 17:12 UTC by Espen Stefansen
Modified: 2009-12-10 04:11 UTC (History)
12 users (show)

Fixed In Version: 2.1.6-2.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-10 04:11:12 UTC


Attachments (Terms of Use)

Description Espen Stefansen 2009-09-24 17:12:59 UTC
Description of problem:
After the last update to easytag, I can't edit mp3-tags anymore. In a directory with mp3s, it just says: 'No file found in this directory and subdirectories'.

Version-Release number of selected component (if applicable):
easytag-2.1.6-1.fc12.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Earth 2009-09-29 21:15:25 UTC
The build of easytag in rawhide is not compiled with mp3 support, as seen in Help / About / Extensions

Comment 2 Ralf Ertzinger 2009-10-10 18:22:14 UTC
Is there a reason for this?

Comment 3 Vasile Chelban 2009-10-17 11:57:42 UTC
Resolution is simple: just add to BR speex-devel and libid3tag-devel and rebuild. Latest easytag version 2.1.6 require both id3lib and libid3tag for proper MP3 support.

Comment 4 Matthias Saou 2009-10-19 14:27:08 UTC
Thanks for the tip. I hadn't taken the time to review the problem until now. So id3 supports should be back, and speex file support enabled too. I've triggered new F-12 and devel builds.

Comment 5 Need Real Name 2009-11-01 11:52:36 UTC
Please can you push this to rawhide?

Comment 6 Adam Williamson 2009-11-01 23:26:25 UTC
Matthias, could you please file a tag request with releng to have this tagged for F12 Final? it'd be a bit nicer than shipping it as a 0-day update, and releng is happy to accept tag requests for important fixes in non-critpath components.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Aron Parsons 2009-11-16 23:46:07 UTC
Packages from Koji work fine.  Any hold-ups or is Matthias just MIA in regards to tagging it?

Comment 8 Christoph Wickert 2009-11-20 13:10:03 UTC
Matthias, I can't find this in bodhi or rel-eng's track. What's going on?

Comment 9 Matthias Saou 2009-11-24 21:24:55 UTC
I haven't gotten around to doing what was needed to get it into F12, sorry :-( It'll have to be an update...

Comment 10 Fedora Update System 2009-11-24 21:27:26 UTC
easytag-2.1.6-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/easytag-2.1.6-2.fc12

Comment 11 Matthias Saou 2009-11-24 22:00:41 UTC
*** Bug 536905 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2009-11-25 14:58:33 UTC
easytag-2.1.6-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update easytag'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12034

Comment 13 Steve 2009-11-25 21:27:20 UTC
easytag-2.1.6-2.fc12.i686 works fine!

Comment 14 Michael Schwendt 2009-12-04 17:02:04 UTC
*** Bug 542267 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2009-12-10 04:11:06 UTC
easytag-2.1.6-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.