Bug 523842

Summary: setroubleshoot: SELinux is preventing /usr/sbin/NetworkManager "unlink" access on nm-system-settings.conf.
Product: [Fedora] Fedora Reporter: Gene Czarcinski <gczarcinski>
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dcbw, dwalsh, jkubin, mgrepl
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: setroubleshoot_trace_hash:7aa898352123f6b5f64ff33a2d65b06b7f888bd70bb09a52d64506fc3efad9a6
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-10-05 18:39:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gene Czarcinski 2009-09-16 20:18:08 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/sbin/NetworkManager "unlink" access on
nm-system-settings.conf.

Detailed Description:

SELinux denied access requested by NetworkManager. It is not expected that this
access is required by NetworkManager and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:NetworkManager_t:s0
Target Context                system_u:object_r:etc_t:s0
Target Objects                nm-system-settings.conf [ file ]
Source                        NetworkManager
Source Path                   /usr/sbin/NetworkManager
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           NetworkManager-0.7.996-1.git20090826.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-5.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-14.fc12.x86_64 #1 SMP Tue
                              Sep 15 03:48:57 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Wed 16 Sep 2009 08:14:32 PM EDT
Last Seen                     Wed 16 Sep 2009 08:14:32 PM EDT
Local ID                      67a647df-3d7e-4918-a55e-a1457c177159
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253146472.608:30): avc:  denied  { unlink } for  pid=920 comm="NetworkManager" name="nm-system-settings.conf" dev=sda3 ino=93848 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1253146472.608:30): arch=c000003e syscall=82 success=no exit=-13 a0=24066f0 a1=23cd960 a2=23d35a0 a3=1 items=0 ppid=1 pid=920 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="NetworkManager" exe="/usr/sbin/NetworkManager" subj=system_u:system_r:NetworkManager_t:s0 key=(null)


audit2allow suggests:

#============= NetworkManager_t ==============
allow NetworkManager_t etc_t:file unlink;

Comment 1 Gene Czarcinski 2009-09-16 20:26:03 UTC
I had just added a second NIC to my F12alpha+rawhide-updates qemu-kvm guest.  After booting, I used system-config-network to add the defintion for ifcfg-eth1 as "System eth1".

NM brought up System eth0" and "Auto eth1".  I used the nm-applet to switch from "Auto eth1" to "system eth1".  I then used the nm-applet edit and deleted the defintion for "Auto eth1" ... that is when I got the SELinux AVC.

Comment 2 Daniel Walsh 2009-09-16 21:06:04 UTC
Dan what files is NetworkManager supposed to edit/delete in the /etc/NetworkManager/ directory?

Comment 3 Charles R. Anderson 2009-09-26 15:55:18 UTC
*** Bug 525762 has been marked as a duplicate of this bug. ***

Comment 4 Gene Czarcinski 2009-10-05 18:39:40 UTC
There are still problems (see https://bugzilla.redhat.com/show_bug.cgi?id=523875) but they do not seem to involve selinux.  I am closing this.