Bug 525762 - setroubleshoot: SELinux is preventing /usr/sbin/NetworkManager "unlink" access on nm-system-settings.conf.
Summary: setroubleshoot: SELinux is preventing /usr/sbin/NetworkManager "unlink" acces...
Keywords:
Status: CLOSED DUPLICATE of bug 523842
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:8e4c15965a8...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-25 16:16 UTC by Gene Czarcinski
Modified: 2009-09-26 15:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-26 15:55:18 UTC


Attachments (Terms of Use)

Description Gene Czarcinski 2009-09-25 16:16:51 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/sbin/NetworkManager "unlink" access on
nm-system-settings.conf.

Detailed Description:

SELinux denied access requested by NetworkManager. It is not expected that this
access is required by NetworkManager and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:NetworkManager_t:s0
Target Context                system_u:object_r:etc_t:s0
Target Objects                nm-system-settings.conf [ file ]
Source                        NetworkManager
Source Path                   /usr/sbin/NetworkManager
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           NetworkManager-0.7.996-2.git20090921.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-8.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-33.fc12.x86_64 #1 SMP Thu
                              Sep 17 15:40:43 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Thu 24 Sep 2009 04:40:44 PM EDT
Last Seen                     Thu 24 Sep 2009 04:40:44 PM EDT
Local ID                      e5295c5f-751c-489e-b611-3bdf4d158592
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253824844.872:27): avc:  denied  { unlink } for  pid=890 comm="NetworkManager" name="nm-system-settings.conf" dev=vda3 ino=39034 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1253824844.872:27): arch=c000003e syscall=82 success=no exit=-13 a0=af4720 a1=a7c7b0 a2=aecb80 a3=1 items=0 ppid=1 pid=890 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="NetworkManager" exe="/usr/sbin/NetworkManager" subj=system_u:system_r:NetworkManager_t:s0 key=(null)


audit2allow suggests:

#============= NetworkManager_t ==============
allow NetworkManager_t etc_t:file unlink;

Comment 1 Daniel Walsh 2009-09-25 16:28:52 UTC
Does networkmanager really need to unlink this file?  Does it write it also?

Comment 2 Gene Czarcinski 2009-09-25 16:37:58 UTC
I don't know .. ask Dan Williams

Releated reports:
https://bugzilla.redhat.com/show_bug.cgi?id=523875
https://bugzilla.redhat.com/show_bug.cgi?id=525541

Comment 3 Charles R. Anderson 2009-09-26 15:55:18 UTC

*** This bug has been marked as a duplicate of bug 523842 ***


Note You need to log in before you can comment on or make changes to this bug.